%2 % LINUX #:4E RS AE Tk

21 515

H Al 2 24 i e % EDA T HEARIZAT T UNIX 8 LINUX 3R 5E R, £2] IC #%¢
TR AT X R RR AT 7. AR EDA THFEZERH
LINUX #:E R4, ZHAEUE RN T, A5 F A QXM I7E.
IH AR A EDA T EA# ] Linux Red Hat 7.2, 407 I 2[5 IH Y (Cadence 5k
AR, ATEENGEHIA (2010 FFHLEMAD HERPLIESE.
2.2 EBEIN

Mdi ST ) VMware Workstation E45, $5 HILE 2-1 s & Mo Bl
F % IEMRIEBERE UL, #:1EJ75 File>Open, #RJ5Z4K 3] F 4% T ¥ VPC2010,
FHFHAE “Red Hat Enterprise Linux”, FH7E IR EESFE “Move” ik,
TP, @ HP RN AR E 2-1 M.

@ IC - VMware Workstation BE
File Edit View VM Team Windows Help
mmp & BGHE (D88 ||@EE ;6 S
G0 2
[» Powered On
= & Favorites IC
& ic State: Fowered off
Guest OS: Red Hat Enterprise Linux 4
Location: F:\WPC2010\Red Hat Enterprise Linux 4.vmx
Version: Wiorkstation 6.5 virtual machine
Commands Devices I [ Options 1
[p Power on this virtual machine % Memory 512 MB
flh Edit virtual machine settings =Hard Disk (SC.. 40GB
(=)CD/DVD (IDE)  Using drive G
[ Enable ACE features (What is ACE?) U Floppy Auto detect
T Network Adap... NAT
@USB Contraller  Present
@) Sound Card Auto detect
EDisplay Auto detect
B Processors 1
Notes
Type here to enter notes for this virtual machine.
< >

L}

K] 2-1 VPC2010 AL

WREBELIE 2-1, HH 2N FEEUE, #1C %iREE “1C”7. #iil
MEMLE, 7E5DF “Command” T/ “Power on the virtual machine”, J& g
Mlo IEHf)E 305 N I 2-2 o i T



File Edit View VM Team Windows Help
Bnre GEHE ([OESEE @EE

Sidebar Ll @ Home % () Red Hat Enterprise Linux 4

= [» Powered On

(% Red Hat Enterprise Lin
= @ Favorites

% Red HatEnterprise Lin

Red Hat Enterprise Linux 3

£

< | 3 <
To direct input to this VM, click inside or press Ctr+G. [OT=1=E.- T

Kl 2-2 F P& S

EHE 2-2 5, FARIFAE “Username :” FIROE “K” —TF, #iil b
ANH P2 RS 7. P2 2MiEst, Wk T2 EDA LR, WRAE 8
F Cadence M5 AT 2@ il 1F A5, H P 448 cdsusr, 2248 A1 Synopsys ) DC
8 PT % L HBHTH07 ASIC it8k SoC #it, ZHN socusr, 2481 NCSU
FOPIAEE SN nesu, S A S IR ERE, RGUK IR RN TS, LB
RGN 123456, Linux #:1E RGLHIT &2 X RN, AT 40— gk
B, UWEHPREENE.

) (=3

Ele Edt Wew VM Jeam Windows Help
Rure BOGR DEEBE DEBE 35

* ST 3 P Hat Emterprive Linus 4
Loy Applicaions  Acsions PRai g @ s rug s 10~
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IEWE R 5 EE B 2-3 s, IXEER O] DUERE, (HRIUNE KA 4
LT

iR ARER, S View>Full Screen of DM BN A Eox, WE
2-4, WIECTER T Jaahid e, METFHANT—EMH Linux BIERGHINLE.
¥ FRARFE ] BR R 7 AT LA 2 B AL E o 7%, AR “Ctrl - Alt”
St T A BSR4 1 91 BT[] 2 Windows. 6 RERRUNL A GRS — 1wk ml R
PREEAE AL {8 R RN BIFE 2 R BoR R e, Eh “m4” Windows
BRI EMIRIE AT, MNRZ&I% Linux #:4E RS T EEE, FEHEE
Linux A1 Windows 2 [ 1%t

[EJ] [

2-4 Linux {ixMbAk 4 B#R1E S

2.3 Linux R4 HIHRF i
Linux #:1E KRG THEAES Windows 5K X B, #1253 B OZ T H R A
ESZNN
(D Mgt
Linux # THENL TG SHIREEE SO, RS RS IR R A
“ICAE7. Linux WA B XHIMES:, AMEFE C . D 85, Frfy “efb” A
LRA—NGE—HIHRS, AT ER. a2 EFHRA “RER”, B



“1” R, RGP HIPA ST ERRAFAEAR H 3% T HSAST Hageh o SO “ g%
17 EAL, BRARAT 4T BR AR AA XS BR AT P AP 7R 725 o A0t A 72 AR H K TT 16,
A& A ER R () H 3R AR i, Blin “/homel/cdsusr/cds/pex/inv_rc.sp”, s 4
inv_rc.sp AAIEAR H 3% T 1) home + H 3% T [ cdsusr 1 H & T~ pex 1 H s
Ty ML I TTVERAT AR /AR, “7 FoRUATSAE, WRCEFHEAN

“/home/cdsusr 7, “./”5 -5 Inome/cdsusr 7254/, 7] LAfE FH“ /cds/pex/inv_rc.sp”
Sk 5 AN I T FH 248 06T 3% 458 7 S PR SC A

(2)  KBEAEM &1

Linux [ BB ST B # Rk 5 Windows fRAREL, (B 328 X SCFtk
SCAF R BTY) L RS L IR S R AR AT AT DALE B A E R #ET, 585 Windows
EAMF. 1€ Linux ~, B3INABEF—BREFH®S, DX BRI
Ko BT EE FEABIRSHEARENER, EARKBEXTEIRE
— AN, FTREEAEIRIRE, X2 Linux 5 Windows HIEZEX A, H T4
JRER, A8 Linux 2045 fir & B 7 VA #GE — % a2

(3> HARUR

Linux #1ERG0E—M “ZHRIERG”, —6i&SE8EHEZ T,
MHPHE B CRIRA S Ny — DT AR SO H S # A — U5 1 e Pk,
Horh e 7eEmima#, JERE 7S ST IERIE 2 S IT 8. B “root”
M4, Edm T R REVS R B OB R I IR SCE . A root & s AT DAE
SO B AT 28RS, Rt R BA7 IR AR AR 53R

(4) R/NEHUK

Linux #:4F R GERIT 4« SO AIAR AR R RN S BURHY, B« X0 KNG 7,
flhn, “cp” Al “CP” A,



2.4 FEARAAEL ]
(1) A

R M cdsusr B3, FESR I ENZE ] —A “cdsusr’s home” 1) E4x,
W7 ZER B —ANE O, KR P S (ILE 2-5).

e —

File Edit View Places Help

[= = [J

cds Desktop CD5S.log
CDS.eg.1 cds.tar panic.log
cdsusr v 6 items, Free space: 6.1 GB %

2-5 cdsusr H 3% K 2

HEZHF NS, REXEE H SRR 25 e B H RN
NS, WSS AN “cdsusr v, BB 3 FPiEsE, BRI “/”, “home” I
“cdsusr”. “home” J& cdsusr ] b —Z Hk, midi/ERidlE 2-6, HrbA 2
¥y H S5 2410 H - oA s i 1

[=1o]x]
File Edit View Places Help
cdsusr ncsu SOCUSK
home » 3 items, Free space: 4.6 GB %

2-6 home FHINZE



WP 17 WEEN TR, MR H S AT DL BAEAT VR D 10 i SCPF . ATy
(115 >) 52 M/mnt/hgfs/share H1 45 TIAT & — A~ 3 Fl/home/cdsusr. /mnt/hgfs/share
72 linux 5 Windows HJ3L 2 H, iZ8E AT XEE £ 5 O 4 /oL,

ILAE [RI3) cdsusr FRSCARET H, 2520 H B NISCIEPE DLORE IS5 LA R A
FER 2-5 1% H v, {8 File>Create Folder #{En] LLg S —ANH %, seigkh—
A, AL Edit>Copy File $#:4E 7T LAFE TUSCHE, {8 Edit->Paste Files $##:1E

ARSI SO XS HRAE S Windows R4E LT 58 & AHIE . 7R I AL AR
PrAEE, dR] PSR SR A
(2) FEIWMLS Windows 2 [8] [ S 15 i

METHRA CRFE B DL, BIANTE Linux B8 0L—A S0k, SRERERNHLIRE
NEHBE, B3] Windows AT LAE KNG . 7E Windows 48 IL—AN S0,
ARSI LE linux BRI b RS XARERAE LU 3, EAERR SO AR 5 302
I H kAR . Linux T ¥)/mnt/hgfs/share 5 Windows T F £/ share (11
A, WTHCE) BT, BN RGEILEREN, F I 223458 S0 H AL
CIE®

JBRAEr S

FE LINUX FR S5 7 ) CRE €8 ) 75 3 XA o SRR 4 8, SR 5 1265 Open Teminal ”

I MAE O (LK 2-7), sl LA a4 T .

Terminal e E]@@

File Edit View Terminal Tabs Help
[cdsusr@suticeda ]$|:|

[2]

[4]
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DA AR i 2 a2 AU IR 1 :
® cd (HxUI¥#) w4
XA FIRBEA AN g B3¢, W A 7 T
cd /tools/cdss X F s A K N —MNEXTERAA RN H 3 (cd J5HZHED.
cd .. HPREALFTHZFM E—HHX.
cd work FISR#EA AT H 3N work 1 H 5% (RBHAFAED
® pwd CR/RMHTHZ) w4

XA R E R Y ET AL B 3. MIRAFTE 3 & H BiEMAN B 3 IR, fA
Za A, REASHEFRITERALE .
® Is (FIR) Wb

XA A RS 0T H X TN, WERFEE RO, FERAls -a.
® cp CGEID w4

$11: cp /mnt/hgfs/share/cnt.v /home/socusr/dc
#12: cp -r [home/socusr/dc /mnt/hgfs/share
HeH M WATM S, NAEZLERE.
5 IR H R

Linux #:4F R GAE RN 5 ZACFAR Z BRI, St R L. ELR
FENLIAEE, AEEERABHNMED (A TEENR), XHBESBIF
Linux FEISCH:, IE#H75 12 5 i Linux S28 g “Action” (WL 2-9), ARGk
£ “log Out”.

£5 Hud Hal Enturprise Lz 4 - Vidware Workstaton

Kl 2-8 BT



IX I 50 P 2-9 BT/ SRB, 338 “ Shut down”, 28 )5 £ “OK”, “ Shut down”
R RN, ARt EHLIE.

@ Are you sure you want to log out?

I:l Save current setup

Action

CJ Restart the computer

= Help #& Cancel @ oK

B 2-9 B B

T e, KHAT Linux BIEH RHUER . ARTHCARR RN 40G
INEY, 23T, ERFERGIERIET, EMPIHERREE,
2.6 FAB B

AR Linux BFEARIE CEA T AR T, LA DAt — 2D 8GE— N B A
T Se 4 cdsusr F P R BrH IR .

cdsusr I 7 2R N S A R BT HRAR HE & VO P . FERXN IR,
Al LA ) EDA T B #4+F %4 Cadence IC5.1. Mentor 1] Calibre 1 Synopsys
1) Hspice. J& M THRIAMSZAEH, el M Cadence ) DFII (8K ICFB)
JAE. XU AR DISCHr e B e il ies, SRR gE . 0710
MR Wit A (DRC), hESEFEXEE (LVS) Pl FASHER
WA (%) JE1iE. HT Cadence FIEHASIHRFAE cds BHRT (XN
/home/cdsusr/cds), GG AALHEN cds A BEIERM /S5 Cadence. 2010 fRA K
WIS R A T2, —FP2 0.5um B A5 5 CMOS 1.2, 4N st02. 7
—fhJ& 0.5umBCDMOS T2, FE44 K st3000. 7E cds HE FHZAFHE, Hi
ref_libs /& 2% % st02 1 st3000, design_libs A sRAR1E [ O iK%, caliber_rules
HJE dre A vs S8R5 75 EL AR S, hspice_models PRAT hspice % =X LAY 2,

spectre_models F1{RAF [ /2 spectre #% zUfF) spice BB, drc.  Ivs . pex 7r7l&iz



1T Calibre [f] DRC. LVS fl PEX (Z4EZHERED izt H .
&A% O, B cd cds f52 3t cds, 7E%i N icfb, [A]1 75, BIT] 5 £l Cadence
[ ICFB % it 38 . W AeusE 2K 2-10 FrniiE O, HiEB] Cadence T.HEA

LR
7 icfb - Log; /home/cdsusr/CDS.log
File Tools Options Help | 1
A OR ITS LICEMSORS AND IS SUBJECT TO LICENSE TEERMS.

Loading oasis. cxt
Loading analog. cxt

mouse L: H: R:

] 2-10 Cadence ffn 2 ke (F2) &

B Cadence M7, miSEH LM “File”, SRJGTETEH 7K 5 rp
“Exist ...”. PUFIXFERIMER AR File> Exist ...

socusr FH 7 fe NS KIS AR A B A SOC #EZ M. EiXA
IRE5 A m) g Synopsys )% 5424 1 H Design Compiler (DC), K F#4#7 LR
Primtime (PT), Cadence fJHzlfi 7. 44k LT H Soc Encounter %5, XMIAHEH
A[ {4 Ff| Cadence ICFB 3355l Calibre, {HixE AT A .

REZHIC Wit THAALE Linux ~F& MMEM, A RFREREMIA L —
{7 B TR, T — M SRR RTHEE (406), Kbt gX
PP ) EDA TR, XU T HAEEN RIS B Beh B A . H
HIVF 2 TH HATEAR O & 228, HRHME GRS T IEoR ) & %A @57
ik, LAGEaRgR 4 KA.



5 3% REERA S E

31 5l5

MATE TG, FATUA—A B #9028 4 5 BT R AR - IR
EDA LRIMEM T, RS TS EE RS e ame, S800E 3-1. it
T2 /& CSMC AR 0.5um JR A 155 CMOS L2, B LEMEATHE
R 02, fFHAESHE (ref_libs) H.

® 31 SRS

w L
P& R~f 2.1um 550n
N & R~F 800nm 550N

3.2 @it E
PAF TR e DA BRI T2 R BnRE, BRMREARDIFEEEFO.
£ Cadence [¥] DFIl 355, MBI AR B SRl sr— A “FE”, “BE” AR—
MR ER, BERESLZXHMRE, FHEERTSEENIT.
(L EshEMAL (2 5
(2) BEN cds Hag (TIFar4 &, fiA cd cds [Hl%).

Terminal

Eile Edit View Terminal Tabs Help

[+]

[cdsusr@suticeda ~]% cd cds
[cdsusr@suticeda ~/cds]$ 1s

ade_wavescan. log design_libs ihnl pex tut
calibre_rules display.drf inv.runl ref_libs

cdsinit (copy) drc libManager.log runsets

cds.1lib hsp 1lvs si.env
common_bindkeys.il hspice_models map spectre_models

[cdsusr@suticeda ~/cds]$ icfb

[«

K 3-1 |Bsh H X AE a4



(3) N Is T2 HiiAIA SR

PENEEIE 3-1. FR, —EE#AN cds B, REAR/E3) Cadence,
XfEFNTE cds B T {74 Cadence ¥146L3CfF (.cdsinit), )33 Cadence i,
AR AT A
(4) fiNicfb, FZ, 533} Cadence 1) ICFB i385

: icfb - Log: /home/cdsusr/CDS.log
File Tools Options Help | 1
i OR ITS LICENSORS AND IS SUBJECT TO LICENSE TERMS.
£

S
Loading oasis. cxt
Loading analog. cxt

mouse L: H: R:

-3

K 3-2 Cadence )= 1 (CIW)

R RS R G N AN, — AR 32 R EE 1, WA
SERED (CIW), FEEELRESY, ZEORRERA. B —ANEOEETRA
FfERE (JLKE 3-3), BijEr LR,

What's New in 5.10.41_USR4.54
File Edit Help = 2

Ic 5.1.41 WHAT'S NEW

The information in this window is current for the IC 5.1.41
release and contains these sections:

VIEWING IC 5.1.41 PLATFORM DOCUMENTATION
STARTING USER DOCUMENTATION FROM THE . cdsinit FILE
ABOUT THE WHAT'S NEW WINDOW

[T el

1. ¥IEWING IC 5.1.41 PLATFORM DOCUMENTATION
To read high-lewel IC 5.1.41 release information,
tool-specific product notes, and uvser information,
choose Help -» Platform Documentation from this window.

2. STARTING USER DOCUMENTATION FROM THE . cdsinit FILE
If you wse your . cdsinit file to start the Gadence
Documentation Help wiewer, set the following string in
wour .cdsinit file: tools/bin/cdsdoc.

K 3-3 ARG REE N



(5) FTHF A
M AR “CIW HH” 1) “Tools” K — A7, HgdM TR
& Fr, SRIE1EHE “Library Manager” (VERE, XX R 4E LG ¥ H#R N
Tools>Library Manager), IXif<x5f i EEHIRFKRER D (WK 3-4), LUSH
AR BN LT .

Library Manager: WorkArea: /home/cdsusr/cds

File Edit View Design Manager Help

| i Show Categories| _i Show Files

— Library Cell View

analoglib
hasic

bedds
bed_tut
cdsDefTechLih
fsc

stl2

st3000

tut

— Messages

Log file is "/home/cdsusc/cds/libManager. log". {j

| IS

34 FEEHIRE N

(6) FALBI
FEPEE PR & D, AT W0 N R4 File>New-> Library, K5 %] 3-5
Fron 8 M. Cadence I3 I 8 DA I 24 LT & D, FINWHERE “He/h

I LRIEOARER, XMABEFE2RERNERN, RILRENE2RE
BR.



7EF 35 FRE LA A TR
BCE. P& ITLLE L, W

B B CHEE AN CREFG,  Name [ sl
IR LR . MR TR, Sy | Dretory
FUEPRREL, (ORI B BifReE (gl mies

design_libs
7E“design_libs” F» AEEBME cdsust” ||

hspice models

~Fo ihnl
[;LJ:W%T&E%E@E b« OK 9 i& ‘ }home;’cdsusricds,’desig'n_libEI
’ AR
]\ng Design Manager
iing MM
N > —He
P) li;ﬁ:j: ZAI’V:F ikne Mo B

DAE R G 3-6 FsiIE H,

A PRS2 . L2
(Technology File) & % ik 2 1)
#: 1% . Technology File HI1E FAARILLE i &
WitHr B, HbwEX 7T “Z” 1
R, T SR B R [x]

s N 0K | Cancel Help
Jir B PR A0 P R e P PR PR R A —

A “odl” th, I 7 T B (R st Technology File for library “tut_st02"
If you will be creating mask layout or

0K Apply Cancel Help

K 3-5 B

o 2R 4 T ok g L
MEEHE TS WRTZE P other physical data in this library, you
15, 1R B A BEAR will need a technology file. If you plan

to use only schematic or HDL data, a

Gy KI5 B i B v I AR A technology file is not required.
1]%1:/‘&?7 LH:’ iz—fj/':ﬂ\é‘@ﬁd\‘l)o

You can: Compile a new techfile
R L ZHEMMIE, —RIE#E # Attach to an existing techfile
Don't need a techfil
3-6 H1 ) “ Compile a new ont need a techile
techfile”, XM IEAEEM 5 — Kl 36 HXai BRI

U S Bl 20 () W T R B A

AT 02 T2, HTFO&GFE—MZLZMSHES02) T, 7] L% Attach
to an existing techfile”, BAFH HaG S5 ERIE B E R B & A, BRAFERH
BRI DUIX BRI R i



M “OK” g, OB 3-7 Front 1, fE “Technology Library” A7 (18R
WEES Jy“anadogLib”, siAa i B4 th I & FE 44, IRAE TE A (I B2 “ st02”.

Attach Design Library to Technology File
oK Cancel  Defaults | Apply Help

How Doshs by tut_st02

Technology Library analogLib
hasic

b, ry

cdsDefTechLib Hel
fsC

st0Z

st3000

K 3-7 e EE R

Attach Design Library to Technology File
oK Cancel | Defaults| Apply Help

How Doshs Ly tut_ stz

Technology Library sth2

b,

3-8 HEH: 02

FEE 3-8 FrniIRE T A
“OK” it 56 M 7 Pty i 3
. HEGHRS, RS  Lbrary Name WSU02
)& R B PE I 4 7 Cell Hame 1y

oK Cancel | Defaults Help

(8) o7 )5 H AL View Mame schenatic
A E &SR Tool Composer-Schematic

SEME S, TSR RbRfEix  Ubrary path file .
Fhome fodsusr fodsfods. Lik
FEabR—T, FExELEE | .

. 3-9 a5 H A
BIREIRLE, W5 HHT T K1 3.9 Bk R LA




#1E: File>New->Cell View, X3t K 3-9 FrsifE H . 3HE “Cell Name”
N “inv” CEARRIE BTN AR, RIE A “OK” RIS, ZREGuH ot 5 2 K g dE
wH (LA 3-10).
(9) 2| iR #E &

BT E S, SRR TN Add>Instance, BT IHBLA 3-11
I [R5

Virtuoso® Schematic Editing: tut_st02 inv2 schematic

Cmd: Sel: 0 3
Tools Design Window Edit Add Check 3heet Options Migrate Calibre Help
&

G;JZ ............

5
@2 Net Expression... Lo . . P e
=9 Solder Dot
i Note A . . P o
R Patchcord... . . . A o
iecll
£ |

. ,t““- s

-

L

mouse L: schSingleSelectPt() M: schHiMousePopUp () : ddsOpenLibManager ()

K 3-10 Ji K] w7 11

Hide Cancel | Defaults Help
Library [ Browse
Cell

View symbol,

Names
frray Rows l Columns l
Rotate Sideways Upside Down
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m“Browse” K3 F o T E BRI A4S, H AL ECE PMOS & fil NMOS
B, ER—EIFHLE (st02) EHEIR, Bl LS E,

_v

Show Categories

—-— P— : Library Cell : View
stz i Eymbal
Library | st0Z analogLib M1 _MZ auCdl
= basic M2 M3 aulws
Cell T becdDs NOIFF_M1 hspice
7 bod_tut FOIFF M1 hapiceD
View symbol | | 4eDefTechLik POLY1 M1 HV spectre
i fsc POLY1_M1_LV synbol
Names st02 POLYZ M1 cap
53000 POLVE M1 res
Array R{ || tut PirMetl
tut_stl2 PinMet2
Rotate PirMetd
cpip
drppw
dppror
sl Hane Zell
o
Multiplier nndep
nnlvt
Length np
Total Yidth
Fhwgar Waith Close Filters... Help
3-12 T4k st02 = pmos & 75 1%

& “Browse” J5, HH2HIL “Library Browser” & 11, 146 st E4 st02,

R Rdr PMOS BHI&ZF mp (L

symbol,

A 3-12), B —EER—
PLJE mt AT LB Add Instance & H <M, IF “Bai” (A

THREKRE
Hide) 7 ti#l

FE e O CBUGE FRREERS), B2 P gide o ), S 0F R BB R E L,
FFrTRE AR s, R E AN, SRR B BT (A 3-13).

Sel: 0

one 1 achSinglese

Tools sign Vandow Edit Al (heck Sheel Oplions Migrate Calibre

1ectPe()

rMuose® Schematic Editing: tuE st0Z inv schematic

M: ackHiKousePopUp ()

3-13 it & pmos &

reataTnat()



FRIARE R T7ETCE NMOS &, 16+ st02 FE i 1) min, [RIRE S AN 2% 18 R T 1
SR R BTN HRIEAB AT S, IXBAS @7 £ analogLib FEH, BREFFSA

vdd, HBZRFFE N gnd (LK 3-14).

Show Categories
Library
fnaloglib

Hide Cancel

B Library |analoglil |lanalagLib
hasic
 cell vdd hed0s

= bed_tut
Epulbol] cdsDefTechLib
B fac
st02
st3000
tut
tut st02

........ Close

Cell View
Trdd Teymbol

usEeCpnp symbol
vam

vCG

VCCE

vocap
wvicd
VoS
vCosp
vilock
vCres
VWS
vCwsp
wdc
wdd
wdda
wddd
vee
veen
wveed

Filters...

Help

3-14 SRS vdd

£, andogLib FEFHITF LS,

PRI R X AT 5 H 1

X HAER vdd Al gnd, [RA )5 4L

R LL_E 2 AF 1218 3-15 o AL BRI, $R8Cd R n] B 7R 28 H] Move (72
) ¥, BB T7E 2 S sl Edit>Move, {8 bR 22 B EN “Move 5257,
SR AE T EAL SRS AF BT AR 2 8 il — 1, AR FHEITT R, 50 AT,
MeE RS R br e sh, BEAMM BEH AT, SFUSEIZAE 1. X
“R—TF, I, BB3” KRIESER Cadence HHFMLE—RA%, HEIHLE
AR, ¥ Ul fifh . EZAEERS 2 KMl Cadence 153 —Mr 2 AR S,
— HHEANF R R, AR B A Th et — BT AR iz s B, dEid
Edit->Delete #EAMERIEAJG,  BbsZ a2 R4 FH S R B 1 5
PERT CAE AR, (HA I IAJRSeH% Esc 8417 2 I AR OHRAE 5 TR E A
RIS, ¥ Esc 8 A 5] Bl BIBRIMEN, H H e H R Z MR — T DU



Virtuoso® Schematic Editing: tut_st02 inv schematic
Omd: 3el:0 3

Tools Design Window |Edit Add Check Sheet Options Migrate Calibre Help

R/ &

0]
“ro

BIASEALy

Euu.
i

mouse L: schSingleSelectPt() M: schHiMousePoplp () R: schZoomFit¢l.0 0.9)

>

K 3-15 $2 i BRI

BFAEE, ) Window->fit # 4 n] DUE 8 PHAL T bt b O, IR e B4l
s XA ERAR AR .

Virtuoso® Schematic Editing: tut_st02 inv schematic
Cmd: Sel: 0 3

Tools Design Window Edit Add Check Sheet Options Migrate Calibre Help

i Instance... i
B’ Wire (narrow) w
& Wire (wite) W
i} Wire Name... I
@2 [ Fin... p
N B Block... 1
@ 2 Met Expression...
=, Bl soider Dot
i B Hote
i B Patchcord...
‘f>;°
o4
M
T .

3
3

Cs
-

5 B

mouse L: schiingleSelectPt() M: schHilousePapUp () R: schZoonFit(l.0 0 0)

>

3-16 EFFIEL
2R tIE L S B N Add> Wire(narrow), LI 3-16, RIS AT LA



T 1 72 300 A R PR s A5 FE e . VR, 7ESRA T R Bk R A IR
Pbse, Bl Add->Instance AU “i7, BRBCE A IO TRGERE, 2k K P
BN “w”. fUAdd->Wire(narrow) LAJE,  BRBR ZE S D RE st B e SCREIZL T, 2R
‘IR (B MOS BRI T) R—TF, MIFAR, 3Rz, meatERBELE
BERPE. TR, A, HASEBARARRIT . BIZLRAL S, R
AT, A NRITTAS R LR, AR SR BRI, W EE AN R . EL
SR JE, MUK 3-17.

3el: 0 3

Cmd: Wire
Tools Design Window Edit Add Check Sheet Options Migrate Calibre

mnouse L: mowseAddPt()

M: schHiMousePoplp ()

Foint at starting point for the router or snap to diamond using the "s" key.

K 3-17 2£HEL

R: Toggle Draw Mode

HUAE 7 Z A L H
Hide Cancel | Defaults Help
Fin Names |PI
o - . N
i fF52 Add>Pin. X Direction input Bus Expansion 4 off . on
LK 3-18 Fis Usage schematic Placement # single . multiple
E{J’Tij 1, iﬁj}ﬂ Pin Hﬂ'% Attach Met Expression: 4 No - Yes
? J\{ 7%: 3[55 :J:% 77 I_SJ Py Hong
. i Detai Mot Hame
(Direction) . R4 :
Fant tpkin T Fiid Sivie Stk
B R Bk, A : : —
Rotate Sideways Upside Down Show Sensitivity =»

K 3-18



input. output. inputOutput 5. EZS5 R, i Design—>Check and Save (I
3-19) KB HAFTETE 25 1 808 R SN s, IRAFENE, REe
PR IRES R, A RS T 2 AR

Virtuoso® Schematic Editing: tut_st02 inv schematic

Crmd: Wire Sel: 0 3
Tools Design | Window Edit Add Check Sheel Options Migrate Calibre Help
Check and Save &

B/ Save (needed) 2

3 Save As... 3

@ Hierarchy

G"12 Create Cellview

N | Hew...

(_.2 Open... 5

<. [l open symbol...
i+ | piscard Edits...

152 || Make Read Only

o Frobe

{>n° Flot

}}/ Renumber Instances...

'l

wom

mouse L: mouseAddPti) M: schHiMousePoplp () R: Toggle Draw Hode
Point at starting point for the router or snap to diamond using the "s" key.

K 3-19

-ﬂ&‘

Cmd.

Tools Desigh Window Edit Add Check Sheet Options Migrate Calibre Help

2 & [

0l
Y

S |3 E s

mouse L: schSingleSelectPL() M: schHiMousePopUp () R: schHiCheckandSave)

»

K 3-20
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Vo ¥ Esc REIBIBGARMERR, £F ZERMSEIF Lo —T, S ol
DLEAE), il i DM )EME (Property) #2480 (WL 3-20), it 44k
FEMER O (B 3-21),

Edit Object Properties

OK | Cancel | Apply | Defaults Previous Hext Help

Apply To only current instance
Show system W user H CDF

Browse Reset Instance Labels Display

Property Value Display

Library Name | 5t0% off

Cell Hame g value

View Name symbol] off

Instance Name | ¢ off

Add Delete Modify

CDF Parameter Value Display
Bndel Mg nrn off
Multiplier L off
Length = off
Total Width B00n off
Faumser Wiith B00n M off
Famers 1 off
Threshold In 1 off
Apply Threshold H off
Gate Connection # Mone . Top . Bottom . Both off

| em wintar usan. 1 10 M nff

& 3-21 mos & & It

%% 3-1, ¥ NMOS B K E &M 550nm, P& 58 B HCN 2.1um. ¥E
B, BERSTHAESRA M, RFEE 5500, KRB EMERN, &
teagiimbEM, MRACS T M, BESER MM T,

BRJE, AU &S —k Design>Check and Save, X JR¥E E F{ETEEL
HEEFRE, RO IZRIES S A Spice ME.



(10> A=A 5 HL

R E G, BRI RE, 2B — 8, DURTER R
BET A7 S, BT ER T EA R R A X B ST
PABETERE S AR L, X BTl B IR BT

M D B AR R S A B B K B3 /E 9 Design—>Create Cellview—>From
Cellview (LI 3-22), PATIZARAE G R I BUR IR BLE] 3-23, 3-24 S5 E .

Virtuoso® Schematic Editing: tut_st02 inv schematic

Omd: Sel: 0 3
Tools Design | Window Edit Add Check Sheet Options Migrate Calibre Help
Check and Save ]
Save (not needed) 2 [
Save As... 3
Hierarchy
Create Cellview

€ K

From Cellview...
Hews... From Pin List...

Open... S From Instance...
Open Symbol...

{isnard Bt

Make Read Only
Probe

Flot

Renumber Instances...

P
/?m

0l
o

AL ALY

i

1l

{ I I
R R

mouse L: schSingleSelectPt() M: schHiMousePopUp () R schHicheckindSawve ()

>

EE:

3-22 AT S LB R AR

QK | Cancel | Defaults | Apply Help

Library Hame tut_st0Z Browse

Cell Hame inw

From View Mame schematic To View Hame 3‘5’“1‘:"3];.

Tool f Data Type  Composer-Symbol

Display Cellview N
Edit Options u

3-23 5L E e B 1



QK | Cancel| Apply Help

Library Hame Cell Hame View Name

| tut st0g iny symbol

Fin Specifications Attributes
Left Fins & List
Right Fins |7 [ List
Top Pins List
Bottom Pins | List

Exclude Inherited Connection Fins:

# Hone Al Only these:

LoadfSave Edit Attributes Edit Labels Edit Properties

3-24 FF5 ik

REEE DN ERARBE, Rk d “OK” B2 ILA 3-25 Jroift5
T o

_____Vinuoso® Symbol Editing; tut_st02 inv symbol
cma: Sel: 0 o

Tools Design Window Edit Add Check Options Help

mouse L: mouseSingleSelectPt M: schHiMousePoplUp () R: schHiViewToView()

>

3-25 540 K g v



R iR L bR b2 5 SR B g i ds BT R SE A S TR, 4B 7S
R B gmiR A IRARAL, S A RbE T H DL R AE T kAR LT A [

HEAAE S, A A AT S T, (EX T2 8], Sl 28 B2 2L
NE WHEBRAF T IR, Blhn SO #s v = # B0 5 Pl .

K s ] @instanceName] & K5k “ 7 12555 N NasfE i n “fite (2
D" AR Wy 1155 FFRA—R, 5 AN —. [@partName] &3 M)
JE R AL AR . AEBRIXLEZRR, A3 B A& AL E .

AT S Pin, 48X ABEMIBR . LEFEIERTHIRA, wi
B, EARMER. SKERIEMZL R RER SRR, SRR, Z7 ME
RIEWH.

B4, M3 (Move) #A/ERANSFARR, JEMESEITHE, 24 NE
3-26 Finfital. B EEEE R Edt>Move, PURHREE “HA—TF HER, MIT
A, WAES) AR TR,

Virtuoso® Symbol Editing: tut_st02 inv symbol
Cmd: Delete Sel:0 4

Tools Design Window Edit Add  Check Options Help

0l vy
AP AL

D% BB EBA

anceNamel
amel

ous eAddPt () M: schHiliousePopUp ()
= | Foint at o m ct to delete

K]-26 1EEATF 5 AR

P55 o B 95 10 I 28 45 4F 75 B S 7 Add->Shape>Line, i [ 8] (#) )7 i &
Add-> Shape>Circle, RJEHRMETRMAR—T, RIFERE, RIMERIR.



A CVEAE R e, SRR B 8l s BRI AL B

7 G Virtuoso® Symbol Editing: tut_st02 inv.symbol i Bl - =1=]
Cmd: Move el: 4

Tools Design Window Edit Add Check Options Help

O mmmmmmmmmm AddPE () M: schHiMousePopUp () R: Rotate 90
= | Point at destination point for move

3-27 NN Pl (A T ik
o 2)) 15 Pl 1) 7 2 SR i B A X (Edit>Move 8id% m i), ARG ER G R
—F, fadt et Rl fizh . #2ah 2k 2 e My i e, SR FAIT A, HA2ah.
MENLLE T YU, XA Pin (& FR < BEZ #23) .

i __Vinuoso® Symbol Editing; tut_stoz invsymbol ... ... |SIC1E
Sel: 0 a

Cmd: Move
Tools Design Window Edit Add Check Options Help

ouss L: mouseAddPE)
= | Point at abject to move

M: schHiMousePopUp ()

3-28 LA iEEuLiE



ST IAMERT DL “Fifd” (Stretch) #AERA KN, &/ B mE 3-29,
il “Design>Check and Save” #:4E, & ICiREIT],

g

Add Check Options Help

&

A

OENC)
~ ~

AN ===

anceNc
crtNamel

e L: nousshddPt() M. schHiMousePopUp ()

nous
= | Point at object to stretch

(olme| s

3-29 HRJEHFT LK
Stretch #R1EJ51% /2 55 iU Edit-> Stretch B GE Blbr, SRR EEE AL Fs—
N, IR, FEE.



(1D # B

S E A R P S S YR RE 07 B, EXRh 5 V2R S 5 1 iR ] 5 R
BIXTEE (LVS), AHEF IR BRI T 52 ) i — A R A,
FEX AR P w38 FE A 100 A S 34 5 5 R IS 5 1

Library Manager: WorkArea: (home/cdsusr/cds E]@@
File Edit WView Design Manager Help

 Show Categories _| Show Files

— Ubrary ———— Category Cell View

Trut_stoz |1nv ‘schematic

analogLih inv schematic
basic symbol
bcd0S

bed_tut

cdsDefTechlLib

fsc

st02

s5£3000

tut

tut_ st02

— Messarges

Log file is "/home/cdsusc/cdslibManager. log". ﬁj

Lreated new library "tut st0Z" at /home/cdsusc/eds/design libs/tut stOZ

A e

K 3-30 15 Ho AT AL IR i e e

17 A I JE B — M 5 B AR S SE R — AN, H B 5 cell 722
R EPEER, ANEEAE cell T, ¥RIRREELZE (LK 3300, AEH
File>New->Cell View #E{EE T ZA A .

PATIZIRAE g t— AR & O, WL 3-31 C T RE I BIAE S AT & D f5
M, FEH—T), ¥ Cdl Name 5N inv_tb, (CUEATUMERILE ST, Hi
UFRERE I R B 2 inv I LD



Library Manager: WorkArea: /home/cdsusr/cds

File Edit View Design Manager Help
¥ Show Categories Show Files
Library Category cell View

frut st02 Hror ischematic
analogLib inw schematic
baszic symbol
bcd0S
bed_tut
cdsDefTechLih
fso
sth2 OK | Cancel | Defaults Help
st3000
tut

. tut_stoz2
tut_st02 Library Hame =

Cell Name Aie_{E5

View Hame schematic

Tool Composer-Schematic

Library path file

/hone fedsuse feds fods, 1ik

Messages

Log file is " /home/cdsusc/cds/libManager. log".
Created new library "tut_stOZ" at /home/cdsusc/cds/design_libs/tut_st0Z.

K 3-31 Gy B R

Virtuoso® Schematic Editing: tut_st02 inv_tb schematic
Cmd: Instance Sel: 0 5

Tools Design Window Edit Add cCheck Sheet Options Migrate Calibre Help

Add Instance
@ Hide Cancel | Defaults Help
@;2 || Ubrary tut_st0Z Browse
i
S cen in%
&? Vi symbol
= ew L
= Show Calegories
Hames ;
{>~0 Library Cell View
Arra; Rows tut_st02 Hnw symbol
it Y JERls 4
& analoglib inv symbol
" potats basin inv_th
hecd0s
j}/ hed_tut
m cdsDefTechLib
@ om fac
st02
s£3000
tut
tut st02

Lo
- >

nouse L. mouseAddPt() M: schHiMousePoplUp () R: Rotate 90
Point at location for the instance.

olm| & 8

K 3-32 W B A R AR 2%



0 a2 T = 1 S AL AT v inv, {8 Add-> Instance #1F 5, A
Browse, 745 £ tut_st02 4 (BT i 20 B 2 37 1 P D ke inv B4 5 (LI 3-32).

cmd: Move sel: 3 5
Tools Design Window Edit Add Check Sheet Options Migrate Calibre Help

O mouse L: mouseiddPt() M: schHiMousePopUp ()

= | Point at reference point for move

3-33 2l fi FL R A

SRIG B E SR vpulse. ELMHIE vde, HLIEFRFS vdd, HIZEFFS gnd Ail—
ANHEZ (cap). IXEELRAFHIAE analogLib H s

8 H Move #:/ERE B 24 LAEEZL . 3X BGE /41— TR N4
Jii%. 1Pk Move BRAERE, SRS 7E LA T7 Z R R Bl i) dsAF S0 T BRbR e B R
H 7 —AME, WEZER SNSRI, SFEIISEN &S CGHREE, A5
FEHAR RS LS, I A, BIER, Bl B LS R R
Ba) 7o XM ERAEHIE T B AP DURIIN S .

Cadence 70 VFAE 1 i B (&I A I 9% DUERAT CILIET 3-34), ol dnm] AN o i
PE N —/ AR, B2 B 388 Ko i — oA ax, Aa5E
AR el R . Cadence XM —AN R B B NEAN /IR 53— R EE,
AR 755 F— ML E B EREARAL.



Virtuoso® Schematic Editing: tut_st02 inv_tb schematic

Cmd: Move Sel: 0 5
Tools Design Window Edit Add Check Sheet Options Migrate Calibre Help
Undo
B/ Redo
& Stretch
Q} ..... Copy
2 I Move T
%
(J ..... Delete i
;2 | Rotate Lo
”J\ ..... Froperties L
N Reset Invisible Labels |
152 | Component Dispiay... [N
e | N Alternate View 000 e
15° | select [ o
| Search | A
5 | e Lo o
~ Route Fight 5 | R Lo
e Update Fins From view... R
X I .
J“",t .....................................
Jn
=
|
O mouse L: mouseiddPt() M: schHiMousePopUp ()

= | Puint at object to move

P 3-34 i 38 DA

P8 LR A 7 202 Edit>Copy, PREEHEDY “c”, & H A M PRaE ;2
HRJE3p N

T MRE R ERAER “REBOR”, HEW SR — DR, WHRRGA
RAEZXIR “BE” —T, SAPKZREHMBRER. X4 #{F 12 Cadence #fF
s AR, R s e A R RIS, SBi% Esc i, )5 HEED. Kl 3-35
e SRR TBOR AR T, 22 (0] 218 A 7oK 25 AT Window > fit 345 .



Add Check Sheet Options Migrate Calibre Help

@ Q)3 o

o)
/‘-N

n
~

L (. tuu. bl vy
5 » kryeet

»

mouse L: schSingleSelectPt() M: schHiMousePopUp () R: schHiMowe ()

P o \B

K 3-35 JREBHK

EXRA R )R, EaBEREFSERNSH, SN . 5hBX
vpulse H)Ja ., J7iE2% Esc B RERAEA, EHizfE SR (A—1), FE
b fE R L S A HE B I AR, R LA 3-36 Fs @ It .
vpulse 5 5IRMZHYE (LERCEEE CAD) HIEFIIE A, FEXREMSH
LU
® DC Voltage

RASHOBRS A E R, B RER 75 E E R A W2, —Mk
BN O HIFT. ¥R REA 0, AEBMABAL “V7, “V7 AN, HOH
FEies
® \/otagel

12 0 N ZIH S, AIJe i R FRIREAE, — &R oV, R “V7 W
ANEHN
® \/otage?

WA 5 Votagel M HL AR, U1k Votag2 B 1, Mix{EE 5 i HE
AR, TAFRIEM 3V, ZMEmS 3, LTAFREH 5V, ZEMmS 5.
® DeayTime



55 L URBRAR I (] B9 Ins RIAT
® RiseTime
ETREbE, S MEREEAR R CETHTRRED, EROhAE O E, —
FEAE 0.1ns 3] 1ns, HUHT55 F .
® Fal Time
NEERFE], g BRI RIRER, ERONIE 0fH, —fRAE 0.1ns £ Ins, HUiR
ERCREAL LR
® Jikit i
15 %) Votag2 Ja PRFFIIIN TR . — R NN B A 4 .
® Period

G RS E R E, Oy ns BRI

o Edit Object Properties
OK | Cancel| Apply | Defaults | Previous| Next Help
Apply To only current instance
Show system W user W CDF
Browse Reset Instance Labels Display

Property Value Display

Library Name | @nalogLil off

Cell Name vpulse off

View Hame symbol; off

Instance Name |V1 off

Add Delete Modify

User Property Master Value Local Value Display

Ivslgnore TRUE off

CDF Parameter Value Display
AC magnitude off
AC phase H off
DC voltage v off
Voltage 1 0.0 % off
Voltage 2 iv off
Delay time g = off
Rise time 100.0p < off
Fall time 100.0p 5 off
Pulse width 5ri s off
Period 10 = off

|33 1

K 3-36 {5 5iEtE



BEEN — R MEX S H AR R R, H A N 2R R B
Y, BIERZEEREAWR, Bl <7 BAURT “Nkeh " 5 ¢ BT
[a]” Je “ N B Z

HYE vde P RA—ASHFERE, WERHBEE (Vdo), HEHE T/ER
RS, MSEKESIRRZE 1 BB, X st02 T2, GERMEE 3—6V
Z I8

AR PR ZE, BROAR 1pf A8 T ARSI AR AR, T RATIURL
BRI AR 2, TR AT AT 0N 0.01p, fif R ER AR 20 AT I AR 4 5 R 75
TRE

PNPTEI T, MR Bl & LRI 2HR, SI0E2 A5
MR AT, WEBIEIIRAEX 7. SR ERAETTEZ Add>Wire Name,
HPLE 3-37 JF DR A ALY — U (R0 B8 ), IR IRUURE L . KR
BELRAE T2 Cadence FA 1HF 55

Add Wire Name

Hide Cancel | Defaults Help

Wire Name |Met Expression

Hames ay
Font Height 0.0825% Bus Expansion 4 off . on
Font Style stick Placement # single . multiple
Justification  lowerCenter Purpose # label . alias
Entry Style  fixed offset fhnndny Dlopiny € horaonial L varing
Show Offset Defaults
Rotate

K 3-37 N2 44 FR

FEAL M 2% 4 I i 2, AR —ENRE 4, ELBRWRE A,
DRI A A5 P X 2% 40 ok A B gt i i 2R PRI ) B, S 19 AR BRAR G I, %m0 — 2%
FE, AR EARRIB AR, AU 2 TR A ROERAE R T, XMOTIAEL IR
2% LI B ARBE AT DA PR ke R ] 1 28



K 3-38 Mt s A 2 S 2

B¢ J 2 ) B e i PR 2 ) 3-38. 4 ] Deesign—>Check and Save £ 7 Ji5 il
LT B T



(12) JashB it A5

15 BT EAE R PR S (Analog Environment) FE(T, 78R B K 4w 45
& CE 2 84 /E Tools>Analog Environment, $HUATJ& st < i ILE 3-39 FiRs i
e T H) SRR SR A i T H, Bl Cadence H C.H spectre Al
Synopsys ] Hspice. PiFi{j 5 THAEME EJLFR2ME, (HE/ETEIBE X
A, LAUNE Sedr 4 spectre (M4 Uik

Status: Read T=27 C Simulator: spectre 6
3ession Setup Analyses Vanables Outputs Simulation Results Tools Help
Design Analyses v-%
# A s o Enabl
Library tut st02 Type I il (FL N
40C
Cell inw_th
i
View  schematic ‘T3
Design Variables Outputs [Ej
#  Hame Value #  Name,/Signal/Expr Yalue Plot Sawve March

Flotting mode: Replace l

3-39 FRAUE T IR

spectre /& M FATASEEOAMG E T H, NRBUERE, HAEnT DU 22 T
Ao Mg B Setup, 4% Model Libraries, <xHiFLE 3-40 i M.

spectre0: Model Library Setup
oK Cancel | Defaults| Apply Help

#Disable|Model Library File Section "
{madiia
funids

i

fmpwn

Model Library File Section {opt.)

Fidi Dradarts i D P Browsse...

K 3-40 AN e



AdHZE IO “Browse” 45F 3| 3-41. 7EH P 53k spectre_ models, X
TP E B 3-42, 2R Ja Xk “ 027, 326 7 H A i) s05mixdtssa01val.scs, £i“OK”,
2EF|HE 3-43.

Unix Browser Unix Browser

OK | Cancel| Apply | Open Help OK | Cancel | Apply | Open Help

File File
| spectre_modeld | | |

ihnl/ .. (Bo up one directory)
inw. runl/ st02/

Lws/ st3000/

map,
pexs b
ref lihs/
runsets/

spectre models/
tut/

ade_wavescan. log 1
cds. 1ib

Current Directory Current Directory
Shome fodsusr fods / /home fodsusc /ods/spectre_models

K 3-41 F-HAET K 3-42 ffi ] st02 N 7Y

spectre0: Model Library Setup
oK Cancel | Defaults | Apply Help
#Disable |Model Library File Section e
fHgabia
i
fown
Model Library File Section (opt.)
/home fcdsust fods/spectre_models/st0Z/s05nixdtssallvll. scs £
Auld Ddats {Eing falt g Browse...

Kl 3-43 A EA

PLTE section (opt) FIEEFEND tt, RIS “#8 T 24 ” (Design Corner)
BAT M. ARG “Add”, B s “OK”.



(13) W H

PR REFEHTRA, #1EA Andyses>Choose, £ HBLK 3-44 PRI &
o BN RAOABRES (tran), (MBEES 70  EESHS (5 L T B ), IX BN
20ns (LI . H spectre B, BAFEShIRE DK, & “OK” BIT],

C ng Analyses — Virtuoso® Analog Design Environn [E3}
OK | Cancel Defaults Apply Help
Analysis # tran dc ac noise

& sens dematch sth
pz sp envip pss
pac pnoise pxf psp
qpss gpac gpnoise gp=f
qpsp

Transient Analysis

Stop Time | 20n

Accuracy Defaults (enpreset)
conservative moderate liberal

Enabled Options...

Kl 3-44 e E

DT JE SRV E BE, BT #4E: Outputs>To be Plotted—> Select
on Schematic, AT 5 i B2l & M ILE e & LA, 20 0E Y AT A IE B i—
N, XPMESHIBIE S E B R G A a2tk EE, ENEHEERE
—EBERERFSEL, WRSETIH EE B BRI BT .

2

: Selecting outputs to be plotted... T=27 C Simulator: spectre [
Session Selup Analyses Vanables Outputs Simulation Results Tools

Help
Desigh fnalyses ’-%

. &  Type Aroguments. ... ... Enzble -
Library tut_st02 i
cell inv th 1 tran il 20n ves -oc
) 1
View  schematic Ky
Design Variahles Outputs DE:
#  Name Yalue #  Neme/Signal/Expr Value Plot Sawve March
1 ¥ wes  allw no
2 A ves allv no

Flotting mode: Replace

L[?a-a-amk

» 3elect on Schematic Outputs to Be Plotted

K 3-45 & FDIRAS

[



SERL LIS, BRI O RN A 3-45 Fis. i R
MEBE, WM EEEEFRHNES, BARETRABEHEER, 17
HER G % BRI R R IE S, &JE 5 N A EREIE B bRt
Pl HIRFBENKBRBEIE, DRGEFRES, KABIRESHRBIREEE A2
H 3hid 1

PLIEPAT Simulation>Netlis and Run 8¢ st 45 T M N ECHE 34Nt T Lliz
ITHRT, fERHME L LA “OK”, HinTH 2GR, FFIEREIE 2L &N,
MBIV E N LRI RS 4 A BT DL B 377, W& 3-46.

File Edit Graph Axis Trace Marker Zoom Tools Help

SG#EHE [FEBET AR NE Xk []Label

Transient Response m

1] 5.0 10.0 15.0 20.0
time (ns)

3-46 WA TR



(14) BB
H spectre fift B4 73 17
B R BB, A, AT
DAFE W 25 23 #7 10)  ilt b 3
DC =i 704, [FII & 2 piAf 5y
PrafiiR. HIOBEPHATLLUT #
Y£: Analyses>Choose, ¥ HiHi
K 3-47. EFEAFE “dc”, AR
J5 % #¢ Sweep Variable F [
“Component parameter”, %
K B shy A 3-48.
7 3-48 1 /5 Select Component,

Analysis

tran & dc
bl sSens
pz sp
pac pnoise
qpss gpac
qpsp

DC Analysis

Save DC Operating Point

Sweep Variable

Temperature

Design Yarable
Component Parameter
Model Parameter

Enabled

ac noise

dematch .- sth

envip pss

p=f psp h

gpnoise qp=r U
Options...

K 3-47 dc M ik B

SR5 B S N IERE A SmE SR, X SCR R H R 3-49. HEFEE] 3-49

“dC”y /l{_?l\ “OK ”’ E 3-48 EPE(J
Component Name Al parameter
Name ¥ HELNZE (V1 FTdo), U

& 3-50.

OK | Cancel Help
e ViOC
mag acm "AC magnitude”
phase acp "&C phase"
type srcType "Source type"
xfmag xfm "HF magnitude”
pacmag pacm "PAC magnitude"
pacphase pacp "PAC phase"
wall vl "Voltage 1"
wall wi "Voltage 2"
period per "Period"
delay td "Delay time"
rise tr "Rise time"
fall tf "Fall time"
width v "Pulse width"
tecl tecl "Temperature coefficier
tcl tcl "Temperature coefficier
tnom tnom "Nominal temperature"

3-49 ik FEHAHA T

Analysis tran # dc
#f Sens
pz sp
pac phoise
qpss qpac
qpsp
DC Analysis

Save DC Operating Point

Sweep Variahle

Temperature
Design VYariahle

H Component Parameter
Model Parameter

Sweep Range

+# Start-Stop
Center-Span

Sweep Type

Automatic

Add Specific Points

Enahled

ac noise
dcmatch sth
envlp pss
pxf psp
fgpnoise op=f

Select Component

Parameter Name |

Start ||

Stop

Options...

K 3-48 PR &=



fEE] 3-50 HIH S A

0K | Cancel| Defaults| Apply Help
2% i (Start 1 Stop) N 0 A1 3, : :
Analysis tran & dc ac noise
S5 R “OK”, Analog & % . o
% _ gy = pac pnoise i3] psp
Wk 3-51, FPATIIH, AT es Aume Aupss A
1325 DC 1 H &S -
( 3_52)0 DC Analysis

Save DC Operating Point

Sweep Varable

AL
Temperature Component Hame

Design Yarable Select Component
M Component Parameter
Model Parameter

Parameter Name | 9%

Sweep Range

4 Start-Stop

o (s
Center-Span

Sweep Type

Automatic

Add Specific Points

Enabled W Options...

P 3-50 #f e F Y

Status: Ready T=27 C Simulator: spectre 8
Session 3etup Analyses Varables Outputs Simulation Results Tools Help
Design Analyses _%
# A B ... .. Enzbl
Lib — Type Cquments nable :?:HN
Cell irw th 1 de 0 3 Buto.. Star.. yes -0c
- 2 tran 1] 20n ves |4 2
View  schematic I I I
Design Variables Outputs [Ej
#  Name Yalue #  Neme/Signal/Expr ¥alue Plot Sawve March ;
1 7 yes allv no j)/
2 & ves allv no
Plotting mode: Replace [
> Resulls in fhomefcdsusrisimulationfinv_th/spectre/schematic

K 3-51 IERRE AR



SrHEEOFEES - BNDXTPSE o

Transient Response |1—| [C Response El

1] 5.0 10.0 15.0 20.0
time (ns)

3-52 i HArbras

(15) fiiH] Hspice
HTARAS ) S5 A 5E 226 | Hspice #4F, I Hspice 5 Cadence (141,
AJ DL Cadence 1] Analog Design Environment '~ EL#% J5 5 Hspice 4T 1 E 0 #7 .
#E Analog Design Environment J&, HTERIAGEASE spectre, iR AEfd H
Hspice, B /oMl Bas. #AE 715N Setup~> Simulator/Derectory/Host, 44T
JE L H ] 3-63 AR E 1. iy Simulator 5534 14, %+ HSPICE Jyfij 5
TH, RJEH “OK”, XNNER R EAEN, KL 1MERE.

Choosing Simulator/Directory/Host - Virtuoso® Analog Design Environ

Ok Cancel | Defaults Help

Simulator H3FICE

Project Directory | /hone/cdsusc/simulation

Host Mode 4 local remote distibuted
LT

Hemnets Diwalay

3-53 i%&# HSPICE AN/r#r T A



BT RMEBRMEBER, XBEHEEAN Seup>Modd Libraries, I 7£ £ 2|
Hspice models T ] st02 548 hOSMIXDTSSAO0LV 11.lib, 4R J57E section (opt)
WHMANEND tt (LETEMN s, o fso ff), 7EK 3-54 BorfPIRA TR, &

“OK” Eﬂﬂo

OK | cancel | Defaults| Apply

#0isable|Model Library File

Model Library File

K 3-54 IR AN N

HSPICE3: Model Library Setup

shone fodsusr fods/hespice models/st02_model h0Snixdtssallvll. 1ib tt

__ |8

Help

Erepitle
fsianida
[

Brwn

Section (opt.)

Fadid Dalnie Chaige flif File

Browrse...

S8 M Analyses>Choose #1F i B BT, e 70 75 E e P K

gz ik 1E], WK 3-55.

OK | Cancel | Defaults | Apply

Humber of Intervals 1

Stepl 1

Enabled W

Transient Analysis

Analysis & tran dc

op noise

lin domatch
Start I

a

Help

& 3-55 HSPICE {2



Fi Hspice fi DC 74 il E ¢ spectre fij B8, &+ de 047 )5, B 3-55 s i
A8 K] 3-56. 1 46i% Sweep Variable v Source, #RJ5 i Select Source, )&
B S N EEE SR, FRERREE A (From) 451 (To) AP K (Step
Size), i “OK”,

_.:s'i_r_lg Analyses — Virtuoso® Analog Design E

OK | Cancel Defaults Apply Help
Analysis tran # dc ac
op noise fft
lin tcmatch acmatch
DC Analysis
Sweep Varahle
# 3ource ,
Design Variahle ~ Source Name !
Temperature Select Source

Sweep Type Linear Steps

From |G To |3 Step Size

Enabled H

| 3-56 HSPICE 1) DC /3 ik B

Status: Ready T=25 C Simulator: HSPICE 21

Session Setup Analyses Vanrables Outpuls Simulation Results Tools

Help
Design Analyses ‘-%

. #  Type Arguments. ... Enzble = .
Library tut st02 o Tren
Cell inw th 1 de Nl ] 3 1 ¥es Plele

anat 1]
View  schematic ey
Design Variables Outputs [Ej

#  Name Walue #  Neame/Signal/Expr ¥alue Plot Sawe March

1 7 yes yes no

2 B ¥es yes no

Flotting mode: Replace
= Results in homesfcdsusrisimulationfiny_thfHSPICEfschematic [/_\’/.

K 3-57 & IRAS



PLJG 1A 518 ] spectre #H ], J5 A Output-> To Be Plotted 1% £% 7 2 37 B &
ANHES, BT R,

File Edit Graph Axis Trace Marker Zoom Tools Help

SR#E FEkF ¥= N ME Xk Mabe | ]

DC Response

[

=/a B
3.5

2.0
25
2.0
=
=
15

0 5 1.0 15 2.0 2.5 3.0
YOLTS (wolts)

graphl.tracel: /Y

K 3-58 DC 734k

&l 3-58 J& ELI AR AT IO EE R, 0 T fRj B Eg, PR o AT 4t R S B A AH [
B H1 T Hspice FP K& H O, FHilERS spectre 45 AL X .

H A2 3 B0 U2 Hspice U7 45 REATEELY, —f% Cadence M EE AN S H
Hspice, AL Rl 75 V2 #0254



o5 45 R BT EEACERAE A BT U A

4.1 hr BB A

A 1 P R 1D o P P T AR BB i R P BT R . OBZDD #R (mask)
MIBIERSCH, R3S AU N — My GDSI. it B2 —F 7 2 RS 17
A, RERE R BRI RER, Wik “EDA BV, KR 5RZIRA
—EMIXTRCR, BAAFEM . RGN T EREZALEER B 4
PR, TAS R R K Z ERIA S fE Cadence 155 F IR, WA —#5“ 2"
5H#li&Ef ok, W CMOS TZPHIBE, AIIXSE. AL “Z” g EDA THEKT
T, WhREREE ST R, X B ERRESFREERE (LVS) BFR©%
B, H5HETTR. IR ER—F-F s B, (O R e B2 -~ i R % 2
IR AR AL B R B, T — R e R~ 2 th i T2 A S e w), ERRE
A RBR

FR BT AR A A3 T BT 2 BT o 1 TR CRIEES BB R Th
GrtlB e s R8s 1 PO o o 1L DY B GO I /A 1L SV Rl o1 s G S 9 - o /LS
ST RN B A= AR, R Ri—F T2, HA i RS ALK,
R ORI . “FI4E” BB R “A B, — R T
A, Bilhn, dEERHX ) “ZTH &R (MPW) #iH4HZ MOSIS 5t 2 i T
25 TIXMEIN . 2010 4 LS RRAS IO BT IREEIY) cdsusr FH P R AR AE ST
PRALA BT RN, nesu A S MOSIS #L.

FEIE MR, KRBT RLAR A B R B Wit o iR AP b R 1R RS 7
JoE 2R BB B R 07 B8 S e 1, BR AR 2 BB BT 5%, Wi AR T —
AN BRSSO RS, (B R DR SRS . W B 77 2Eid i vt U ke 2
F T B R TR, PAORIEH IR

RIS TR 8 M e A AR ORI, U PR R B W v AS e AR RORERE 1) L B i
B — AN 1) LR Vv AT RSB TRERE IO A B e vt 7o i Il AR U R0t i i T 245 b
R Z AR S % T 00, 81 ) Jet T2 0 S AR P AR 5 B A Rk rL B B 1 5
M o ASEFUN FL 06 A S50 P 6 o i AL T H B SR R B (R R IR AR 5 7, X Pz g
I EL BB “CEAR,



K FENBLH CSMCO.5um RATE 'S CMOS L2 1A K 7 510 FL %
(Cell) [ B )i T %
4.2 CSMCO.5um B 5155 CMOS L. Z & 1HH#i
CSMCO.5um B A 155 CMOS L MVEHBE TN 2 P 3% 1, X B A4

JREEEEATHBIRIHR T

I m =M=l
(L “JZHIR” 1S Sort  Edit Help
ZHWERZ T RE] KA g XK, 7& Cadence (B [dcw |
st02

FRB T AR T2 O 7 B SRR R A S hon oncte
PR VEUR SO P 8 RSSO PR 5B Mnst MPn

“PCELL” B[ DL — Mz LEms %, Au A W] AS NS
RIS 02, BAF WFki% L2 02 T ;m -
MR AR B HBEE, H55% W ]

P FE TR BRSO AR IO, I R 3 Ei EH
EIREDRIEFR “Attatch to” IR, IR “E” & [dcw |
VS 3 BRI RIHG, ATIF layout AL EH
REIE 4L PR “JRIERRET WH (LSW). =
“EEPER P RAR A CREE, Ej:
R % RREER MM E KT (Gt v ]
M dw, %0 FEEEHERE A, “B” K EH
SR ZECEXH, #H, “FHEX” £ 12 v
FIH RSO R “TO”, THESE T F AR A EH
P REROY “active”. “E7 A5 TEM%, M [ ]
FIE 07 W4bk & EDA TAS Mg, s02 Ty M [dcv ]
AT S CHET cdw HRUEAITANEY, e =
“net” RRTLRHEINL, “pin” FRiZER T R [oew |
PRI, <R” &R R E B MR <R B EI %$ =
MR ERR, AR RE R4, REA AN CH L il |

17, Fltn: M1 (drw) 5 M1 (pin) RARKZLE K] 4-1LSW 7 1
B, TeeiRA. L% BRI EEMH drw RBKE.



LA S48 oA 28 B st o8 iy “ =7
(2) STO2 TZMIZEE
® N (TB)

N BZEFRA R N BB (mask), £ CMOS TZH, PMOS &%
HIEZE N B, N B2 PMOS &1 “48”7, PMOS B 1) “/&” B35
IFEAT, U r PSR PMOS 1“7 8% RS YR vdd. 7E st02 FERHAR
A, N BEERRN “TB”, 2 N BHE%SE “TB (drw)”. FifF 14 74
)N BFDXE RN, A3 f /N P T SR () 5, Il ) T e A R A T
fift o
® kX (TO)

fE CMOS L2, NRREHA, ezl RIaRN “HEX”
HIX7, “BEIX” MENERE, FERTREHRE. “HAX” geqiEx

(Active), FHTHiI1ERAFBSE DU X BE5 42 IR HE I« BRI A 7. 7E st02 T
SR, BERKLHRA “TO”, LHIHEXFEERFE “TO (drw)”,
® PJEA (SP)

X2 TARBTEN P+E I FR ZE AR . st02 T 2030 b 44 4 “ SP”,
2l PYEANIX R ZE L “SP (drw) 7,
® POLY1 (GT)

MEMEAN T ZAMZEZ S (Poly), £ 902 1, 28 12w N “GT7,
FEH THIME MOS B MR, ] LR Sk il F s BB HL 28 1) R ARAR - 228 MOS
BRI R ERE “GT (drw)”,
® Ffifl (WD)

CEAMIL” HTEEE S AMAIRIEE 12 N+ PHUAZ RS & RER
I EREAL A “Hefigl”. S02 L2z ar 48 W1, S L ik %
“WL1 (drw)” HeflfL R AR P24, SN fi L IR R /NE X b L 2k R g R
0.5umX0.5um, BEPARRER, WARED.

o &gl (AD

&R LERRESE, BHHA “147, 78 02 FHAR 4 har4 i AL

2 B ROERE AL (drw) o st02 BR324 )R, HLEWEN A2 fi



A3, Hf&R/ 1 ERaiifl s meehitgi, HEmEREdml w2
W3 5 ALER. 2o i iR R SRR i i A2 M A3 2, IR
AL AT, TR POLY L ke B5ikds, )24 81X M2 2R 4 Hot
palifEpes
® &JE LiniEE
FISRARE R ITTHI S (pind.

2t SO AR R B E A BA LT UE, VR RN DB 1, R e —
N, AEARAEC . SRR AN EE A DRC Bk TRAAE, HIlsiRir
BRI M 1, BGREE, 8 BRI B 28 e
4.3 FR BT T Virtuso 3 AR 1R

FEIE G ) BORH &% A1, N B 56 S 2 i e i 4 AL Virtuso HFE A #4705,
H 74K DRC Bl B (Calibre) Wl FHJ7E. 2 IRt al % DL P IR AT
(1) J33h Cadence

Jeit N cds P icfb fir4 5 3/ Cadence, Z L5 3 %,
(2) FTIFEEHE

7£ CIW % 3%+ File>Library Manager, ] L3 & 4-2.

File Edit View Design Manager Help
Show Cateqgories Show Files
Library Cell View

tut_st02 Hnw Ischematic
analoglib inv layout
hasic inw th schematic
bod0s symbol
heod tut
cdsDefTechLib
fac
st02
st3000
tut
tut_st02

Messages
Log file is "/home/cdsusrfeds/libManager. log".

K 4-2 e PEE



(3) @ —AhieE (ayout) #LKE]

FEEE RS T OSBRI “tut_st02” JEA b fidi—F, iz, R
JGi%E# File>New>Cell View, i3 “Create New File” & 11, A& E L]
PR MOS & I, #ed—A4 8 “nmos” KRR E R (layout) fHELIG (Cel)
M. 7 layout TIXLEIESE & “Create New File” B O H “Tool” A4,
HEMHBK T RFFRPERFE “Virtuoso”, “View Name” ¥ H314E N “layout”.

S Cdl Name J5, EE 4-3 KPRAS

- ~ - "
Create Mew File
“« ”» > N axll
[§]
TR “OK” BRI AR — layout A OK | Cancel | Defaults Help
y A} - = = d
AL, JEE SR R E R | it s102
Library Mame =
=8 0y =z
ERR” wr. —
Cell Hame
View Name layoug,
Virtuoso
Tool
Library path file
Jhome fodsust feds feds. LiE
L #
Kl 4-3 g7 hie KL
LSW Virtuoso® Layout Editing: tut_st02 mosfets layout
Sort  Edit Help X: 1.29 Vi -9.87 (F) Select: 0 DRD: OFF dx: dy: Dist: cmd: 6
Tools Design Window Create Edit Verify Connectivity Options Routing Calibre Help
sto2
Show Ohjects @
Minst W Pin
AV | nv | as | ns @
i &
s
A
I
T
n,
—
[L
r
i
e Ao |
KL
0 Jdow] gg
I
1
e
0
< |mouze L mouseSingleSelectPt M. leHiMousePoplp () R:hiZoonBhsoluteScale (hiGetburs sntiin
&
p — ———

4-4 hREgmiE R 1




(3)  WE B

FR P T 7% BRI 2 A B R RSE, A e ([ — e i e AR E
MRS T BEAD RARRE B “BFE”. TERREI4mYE & %4 Options>Display #4 i
K 4-5, £ “Grid Control” T77#) 4 24+, “Minor Spacing” & A%
HINE PR, “Major Spacing” e ¥HAMMS KT EE, “X Snap Spacing” #k5E F bR 4]
B/ NEENEER], “Y Snap Spacing” Y€ BAR A1 i NS ENEE R, X SL R 11 E
SR LIZHRK, LHNEGHRE.

Display Controls
Hl Open to Stop Level
H Axes
Instance Orgins
M EIP Surround

Display Options
OK Cancel | Defaults Apply

MHets

Access Edges
Instance Fins
fArray lcons

Fin Hames M Label Origins ¥ Snap Spacing 005
Dot Pins Ml Dynamic Hilight ¥ Snap Spacing 0,05
Use True BBox H Het Expressions
Cross Cursor Stretch Handles
Filter

Path Display  Borders and Centerlines Size & Style emply

Show Hame Of instance -+ master

Array Display Display Levels D LEiES

4 Full start |G Create orthogonal
Border i orthogonal
Source Stop |20 Edit L

# Cellview Library Tech Library Fle ~/. cdsenwv Browsse...

Save To Load From Delete From

Help

Grid Controls

Type none 4 dois lines

Minor Spacing 0.0g
Major Spacing 0.05

45 WE Wi

KT st02 TZ, UL L 4 ANSEFBN “0.05” (ALK HEETE.
02 [ TR P R B S B B 0.05 Sk, TRIEANRE R K. W SRR TN, W
0.01 K, EARtRRmE, HERFRMEIEH. KU E 4 DNSHEREMFE, AIRIEE
R0 FHIRATEAE 0.05 Bkl L.

TR BRFREITH—MRERE, MHEHEERRE, Cadence 4 H

2N ORAF AT I BB



(&) FAEAELS,
WEM G, EEksdiREmiEss be c+” B/ T Lsw

ir. HEURH ERGEIIMAL. SOE-BNEE

i, BEFE LSW BOHEEREE, ik Al A .

BEFRIZRTER, 008 LSW @8 EATIE R, BIA0 minst men

(EF 46, T TO (dw) BT, B L7l e

LY “TO (drw)”, W] = RTE 122 B =2 TO (drw).

|drw |

F UGl Virtuoso 152 3 B FHEA =
o Ll =
A mBLOEE, REEEE @ =
Creste>Rectangle, 1A BRI 5 T BUbF A i 1 Sy A =
ST, 16 b A e AR SR Ltk S =

“R—T, WL, RS, saERER LI,
FrRE AR RN e F e — K, FERAHE 1. WL
R Bl g iR As IR UG 5 R B E R S AT S AR R — 3. M 47 21
PBRIXETE, RS AD R E S, BIRGREREME L.

N 4-6 ﬁ%%}% |

« | B

X 0.55 ¥:-0.65 (F) Seleci: 1 DRD: OFF dx: 0.5 dy: -0.95

=

ools Design Window Create Edit Verify Connectivity Options Routing Calibre Help

%

D

I\ =IE =P

M: leHiMousePopUp () E: leHiCreateRect()

K 47 il — MY

mouse L: mouseSingleSelectPt



® UARFIEHI A/

il SR AR 5V 2 Edit-> Stretch, AT DL bt [ 4R 7 1 1) “ Stretch”
bR B PR AERRE “s”. AR5 AT EITERIILAR, FATT Bbs 5 Has), B AT i3 Y
RN R, BEEGERSRA N RIS, B3 MG e —T
“Esc” &, BB, FEFTERAE.

® Bz —EIE

SKHPRETTEY, Edit>Move, WA LLE T AFHFH] “Move” ElFrefl
PRAESE mo 1EF Move )G, MEEB B La—T, It AR )fEH63),
EInrR2 3% . AR E T, EIE R K FeiEk B#s), v MESCAE R )
B, EXMEEARE AR, BIFAEE.

o HII—/EF

SERERVE AN, Edit>Copy, WAL T EEA T “Copy” FElbnsfH
ik co L Copy #/EHA )G, 7EE Copy MEE Li—T~, MITAREHES),
XEFREHE RS, BSENMER ST, BIERaE A E.

® JEERIK

HEAAAREREBCRHIXIER “BE—T 7, ZXEGEHECC. LUEEH
THEAE B “-7 80 “+7 RESERER/D, 1% Window->fit #E AT L8Rk

® fif “R”

% Esc BB RBABREER, S THEETR “FUBERR”, A5 RAERRE
MR AL TR, HEShEARRI AT E ] R, BT AR, R BEE
Bid b1 . #& “shift + k” ATRABUBRTAER “R”. fEH “R” s, —REE
Stk Esc A Re VI B H e a2,

® [HERETE

fESCE Ik, Edit->Delete, AL ARSI DIREE SOMMER, LG st
—NETE, wilERizEE .

® FLIKF TN DL

Feik BRI Move B Copy, 1E75 Z /285 DU R A« m—
W7, BVnrE Bkt , ARPRE—DEE ES—T, fits) s,

T UL BB AT AT T — 4R 1, e ER] BLE A



(5) %l NMOS & hi &
ABEE ) NMOS & 1R ~F . W=800nm, L=550nm, H{F %> x4
NMOS &R, ZRAEFHERTHHINMRIR T, FIRKMEXPERRN.

K 4-8

B, fEMREREE EAIRX, A LERE TO (dw) 2, A5 H—
MNE . GIRIXITEEmEVATE T W, Bt ZiE% N 8oonm. A5, A
X FEAEH GT (drw) 2 (28 1)2) 1 MOS B Ik, 22 & 098 B 2
VIS, W2 EE g 550nm. JeEl— R A KR, BNV T ZRBEER, &
PEEATC SRR, MR EIVE R 2 00E 52 R B RN B .

Z d D A TR X 550nm, X A2 BeTHRIUN IR, AEYR DX X 2247 b4
fifL, DMEEZERFEL. FETZ0EEE NHEAKX, Hs02 TZHAHA PE
i BLE PHEARX (JE PHEANRHLT AR NHEARXD . BEAlFLERIRN, DLl
FL5 2 () 18] PR R TR E S /NI AN IR T AR o B AR AME IO B RTEE KR, b
B DRC /& T H, PLT/r4H Caibre i) DRC #:4E 7572

s



(3) Calibre DRC #:1F

JEAENBHRARS BT R e 25 2 7 Wi B et 58 BN #E 4T 1Y), (B SEBR
BelErh, AEZE—ANEEE, HEIT KA. Cadence H CIARFIIE T AA
Diva. Dracula®, X6 T READIReA M, EABIEATIME, HATCEDEH.
Calibre /& Mentor 22 7] IR ESAE T H,, H AT &2 H P L —Fff, &322
SRS K H Tt Calibre k%21 DRC MUUAT LVS M. Calibre A] LSS A
H, A LA SAE Cadence I TFIRAEE . 1X BLAMH 5 — RIS J57%, AT LAMR
Pl 9t 8 T 1 1)K 545 31y Calibres

Virtuoso® Layout Editing: tut_st02 mosfets layout
X 1.30 ¥: 1.60 (F) Select: 0 DRD: OFF dx: 2.30 dy: 0.80 Dist: 2.435 Cmd: Ruler 3

Tools Design Window Creale Edit Verify Connectivity Options Routing Calibre Help

. Run DRC
......... ...' Run DFM

.................. Run LV¥S

Run PEX
Start RVE
....... | Clcar Highlights

..................... Setup

............ About...

mmmmm L: Enter Point M: Pop-up Menu
Point at the first point of the ruler:

R: Toggle L90 X/T

4-9 2 NMOS & [t 72

S E g LR B “Cdibre” T LLE S “Run DRC”. “Run DFM”
kT (LK 4-9), i DRC #iik$: “Run DRC”, [EFELLG i LVS BB, miik
“RunLVS”, %&£ “RunDRC” < H LA 4-10.



Load Runset File

omefcdsusricdsirmnsetsirdre

Kl 4-10 J53)) Calibre DRC

HREAE IR E AT R S B 4-10 BEE ANE, ROV ATREEICH “Runset”.
“Runset” & FHRRAF E—RIER), BikHEAAE, & “Cance” %41, EJZ
E IR, LA 4-11.

Calibre Interactive - nmDRC

B
Bl 4-11 deFE TS



HSERE I T “Rulse” Z5$% DRC HUN . 2RJ54% “HUN ™ & FA i ...
THRHEN ST, IR I 4-12.

’ Choose DRC rules file @
Look in: |shome/cdsustics/ wl & | &&=
] calibre_rules (] spectre_models
1 design_libs ] tut
] drc [ ade_wavescan.log
1 hsp [ cds.lib
] hspice_models [ cdsinit (copy)

7 ihnl [3 common_bindkeys.il
] inv.runi [7 display.drf

] Ivs [ libtanagerlog

1 map [7 libManagerlog.cdslck
] pex [ sienw

] ref_libs

] runsets

File name: |rules Open
File type:  [all Files () w| Cancel

K 4-12 GBI

KR ST RAE “ Calibre rulse” H &, XEHIFEAERIHNANSFHZ, 4
51 “st02 rulse” il “st3000 rulse” (L& 4-13). H 5 E R DRC HI S 1 7E
“st02_rulse” H,

Choose DRC rules file E
Look in: |/hamescdsust/cds/caliore_rules wl & | &5
] st0z_rulse

_1 st3000_rules

File name: | Dpen
File type: |All Files () w| Cancel

K] 4-13 1§ FH st02_rulse = ()




FTIF 02 rulse H B F 4-14 Fios i SCE. &8 “csmecalibredre”, 28 )G
A “Open”, Bla] 2 JFRE .

Choose DRC rules file [
Lonk in: |fhomefcdsusrfu:dsfcalibre_rulesfsmz_rulse -l &= (==

[ calibrexrc.lvs

[ csmcealibre.drc
[ csmcealibrexrc.ad
3 csmcealibrexrc t2
[7 cameocalibrexrc t3
[ =re_ad.rul

File name: |csmccalibre.dre Open
File type: |All Files (%) w| Cancel

4-14 e H ) SC A

PLTE DRC & FHRZA FINSCH T, Rules BOZAR NS M. R, EIXHE
HEE R “DRC Run Directory” BN “/homelcdsusr/cds/dre”, H#tizfT45 4k
AEIXANFHE T, FReiiEE, ST g B8R EL.

Calibre Interactive - nmDRC E]@@
File Transcript Setup ﬂelp|
’TT — DRC Rules File

Inputs :" fedsusricdsicalibre_rules/st0Z_rulsefcsmccalik: J Wiey Load ‘
Dutputs

R Caial | — DRC Run Directory

Transcript | |mome/cdsusricds J ‘

Run DRC — Layer Derivations :

Start RYE

Save..

Kl 4-15 5T H 3%



WE G S “inputs”, 4 “Export from layout viewer” 5532 (K441 i%&
i DB 4-16 s, =B LR B 3 MR AL A Bl GDSIE A Ui ST
o O b A HA e AR 43 5 s AT BAis 4T DRC T,

Calibre Interactive - nmDRC

File  Transcript Setup ﬂelp|
Bules Run; DRC (Hierarchical)  — 1 Incremental
Inputs
Outputs Layout ] Waivers ]

Fun Caontral
E— | File: [mosfets.calibre.db ‘
Run DRC Format: GDEIl =t W Export from layout viewer
Top Cell:  |mosfets |

Start RVE
| Area | ‘

K 4-16 EPEH AN CHF

B 4-16 ) “Run DRC” Al LLiz4T DRC [, LAUJE b ml Ag it —Lify i)
HW, M “OK” BY “Yes” B AT, 551 Caibre i, REiEHERATIAE “Runset”,
H O, BHARAER] “/home/cdsusr/cds/runsets” &, RS Sh BBk RI 7],

1217 DRC 2> HEG AR, HTWEERAESE, K 4-17 1 4-18 fr iR
(I 5% BT B AN A 5 R



Calibre - DRC RVE : mosfets.drc.results [fhome/cdsusr/cds]
Eile Miew Highlight Tools Setup

Help

>

& ~» 4 HP»C W Z

Topcell mosfets : 4 Results {in 4 of 241 Checks) ]

B & Cell mosfets - 4 Results
£ B check sof_check_12_3 - 1 Result

4-¥ertex Polygon

-0.75 , -0.55
° 1,15, -0.EE

B Check &1.noted - 1 Result 1,15, 1.35

B Check &3.1- 1 Result -0.75 , 1.35

B check 827 - 1 Result

Rule File Pathname: fhome/cdsusr/cds/ csmocalibre. dreo
soft_check 12: bulk missing stamped connections from ptap

Cell mosfets : Check soft_check_12_3: 1 of 1 Result

L%

& 4-17 DRC %42

s R IR

S B0 24 HAE R 2R, “bulk missing stamped connection

from ptap” XM IRAE U AR BEER, XA NEE, 1A

I, SE A IR R F LR i B IR = T R

Calibre - DRC RVE : mosfets.drc.results [fhome/cdsusr/cds]
File “iew Highlight Toals Setup

Help

>

= ~ 4 H »C W 2

Topcell mosfets : 4 Results (in 4 of 241 Checks) ]

E B Cell mosfets - 4 Results
-l @ Check soft_check_12_3 - 1 Result

4-Vertex Polygon

-0.75 , -0.55

® W 1.15 , -0.55

O & Check &1.noted - 1 Result 115, 1.35
-0.75 , 1.35

<
B Check &3- 1 Result
B Check A21- 1 Result

Fule File Pathname: /home/cdsusr/cds/_csmccalibre. drc_
Al noted: Al metal density must be »30% <50%

Cell mosfets : Check Al.noted : 1 of 1 Result

K 4-18 W% DRC 4 i#2KAY

“Al metal density must be... 7RESVER), Fone)E 1 HAARTGEK,
PUF PN A2 T A3 THIAR R XA o] E G JT B SRR TR AN 1R, —

258 R 58 U F 5 1



B LGNS RN A 4-19, Hapiz i Wi (dw) JZ24:4], A #E
& 0.5umXx0.5um. SFEHZE AL (drw) 2, AT S RBE R4 H RS2

E 419MOS BiRE CEREEE 00

BT DRC G A=A AR, HIE. WX HAECRGER /N, mtoeml 78—
N

BB AR BB, NMOS & i BT L EE M st02 FEif i, (H
A b ZR IR 3 AT 2 B, DR SRR IR i B v e 2 — RS 3 R S T 46
zx), WIANESRE B st a7

%2 MER2HE PMOSH . d— M EIHLEL, 44y pmos, #1& 4-19 45
HERSH ], B P R EHER 2 N BE, ) TB (drw) 24, 20 tiifE
TR PYENIX, F SPCdrw) 2 224 . PMOS & [ %5 72 2.1um, K 2 550nm,
FK DRC A% T 4-21.



K] 4-20 PMOS & i |8

Calibre - DRC RVE : pmos.drc.results [fhome/cdsusr/cds/drc]

File ¥iew Highlight Tools Setup Help

& ~ 4 H »C W 2Z

Topcell pmos : 5 Results (in 5 of 241 Checks) ]

B & Cell pmos - 5 Results 4-Vertex Polygon
B check soft_check_B_3 - 1 Result

=3.3 , =1.3
B Check soft_check_12_3- 1 Result 285 , -1.3
B Check &1.noted - 1 Result 2,25, 3.4
B Check 837- 1 Result =33, 3.4

B Check &2.f- 1 Result

Rule File Pathname: /home/cdsusc/cds/dre/ csmccalibre. drc_
soft check 6: th_conn missing stamped connections from ntap

Cell pmog : Check sof_check_B_3 : 1 of 1 Result

K 4-21 HHETFCYFAALER] DRC Jr]

AN AR VLR TR, SO AR, R PR R IR R AR
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W E—E RS LR 2, BT TR R R L2030 EE R
SRLEHNGAESA <27 WET, HEiRFEARGH 772k 5e s 56 AT AR E & ik . H
AR ZI R, B A () e T 36 3047 i B Bt & EUER BRI 1 . g
o LAERCR, A=) s RME— N REM (PDK), KPS — S8
fF (PCELL) J&, HlUngimse®ln) st02 . 75 PCELL A & Fh 8=
HUL B . BB S8 R IR R TR rT B 1 2808 2L, BLORIET 2
BN, {8 PCELL AJ BLKR KM@ B 22 il #EAE, WA ZIFAG, FATEZEAN
HIXMP T T

FER 7 50 LR R BT I, — AR 22
G5 — T 5T S G LM I T FE R ARG . MR ot .2

B, DMEFE G2t Re AR P, 7k *
AH PSR BT T, AR B T R IR ) v RN 4

15um
JELL T R WK 5-1 B, % LA S ThRE
BRI R B /N R ST T, ASACss 1) R

FER TR AR I SE UT . ORAIERR & 5 )5
M5, AT IR S JE B E T B, B
LVS. FEFA TR Bt i, LVSH 2 H Calibre
e, HARVEJTVE S DRCHRAEAL. LV'S $RA1E 1 5 2R 20 S 4R 5 R 38 PR 1 ik [
AR Spice ISR HLEE MR, ARG LB “MR” H—3 .
5.2 #T PCELL fIRR BT 7%
SRS RS R] DA% DL R AP IR
(LD fEinv FHE—MRESER A,

BB inv IS B E QR A, Bt ELR cdl 4, fEZM cdl £
T IR RS (B 5-1), AR DL R BB AE inv . A Calibre
BEAT LVS HRAERS, — T 2R o 2 AR I 5 i B R S IE [ — A Cell T, 50
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EAELLERRIO. SRS TE R B AR 32 3 RiAT 0 N 4/E: File>New->Céll View.
R E O (LK 5-3) H0K Tool %4 Virtuoso, View Name 5t H 3145 4 layout
T o PUATEAE SR DL 5-4 Brs iR g & 1

===

iew Design Manager Help

Show Categories Show Fles

Library Cell View

Layout.
schenatic

synbal

ut02 v

analogLib inv
basic

bedis

bed_tut
cdsDefTechLib
foc

st02

53000

tut

tut02
tut_st02

Messages
Log file is "/home/cdsust/cds/liblanager . Log”

Kl 5-2 @7 inv AR B E

(2) 24 NMOS &

Create New File

0K Cancel | Defaults
Library Hame rtoz
Cell Name AT
View Name Legat
Tool Virtuoso
Library path file
/home fcdsusc fodsfods. Lik

Help

K 5-3 MLIESRA %

FEAE ] PCELL FEBEAT RIS, NMOS & Ah H E2e i, M st02 2 i
FHEP] . #AE R TERR B dn i 5 1 bk $E Create>Instance, SAJE 7R H & [
(L 5-5) £ “Browse”, #RJEF 02 FEF R “mn”, Ik View Ay layout,

K 5-6.
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Library Browser - Create Instance
Hide = Cancel | Defaults Help Show Categories
Library Cell View
Library | tutDZ Browse lst02 I TLayout
Cell analogLib Ml M2 aucdl
. hasic M2 M3 aulws
View layout; bed0S NDIFF_M1 hspice
. heod_tut PDIFF_M1 hspiceD
Hames . cdsDefTechLib POLY1_M1_HV ivpcell
fsc POLY1 M1 LV Lagout
B N ~ st02 POLYZ M1 _cap spectre
Mosaic Rows |1 Columns | 1 53000 POLYZ M1 res symhol
tut PinMetl
peitay |0 peitax |0 tot_st02 Pindfet2
PinMet3
Magnification | L cpip
dnppw
dpprws
2k Rotate Fi % Sideways é Upside Dow fpl
mn
nndep
%2 3 =]
5-5 iinasft Lt
mp
Cose Filters... Help

K 56 3 NMOS &

KK 56 fiant I, 7E& 5-5 k& “Hide”, BRI 7ERR & 4kE & 1 E 5
mn RS, EAERME S, RInDE 28y, WE 5-7,

5-7 BRIUIREH NMOS &

DIIEREE B2 AR RS, 4% “shift + 17 B ([RINFZBNED, SR SR
JE, HiEeERIMT (LB 5-8). #% “Ctrl + 7 [HF|JFEE IR,



K 5-8 NMOS & [t 40

(3) BHURIEZH

I BAbR e B ez A, ARy GBI GIaHe), 285 sl B 2 4
BV Ebr 5 T P g e 1 & R B AR RD , K3 1B 5-9 o i
JERYEE L, S “Parameter” FEIUH/NTTH, MBS S

Edit Instance Properties
OK Cancel Apply Haxt fravinus Help
Attribute Loumaniivily 4 Parameter Property ROD et Lomnan
e gl by
Length S00g
Total Width 2005
Fhuger Wiith 8005,
Fagars b
Threshold 1,
Apply Threshold u

K 5-9 MOS & )& 1

¥ Length &4 550N, FH 55 E—#. X558 F 71 “Bodytie Type”
(ARERRRD AN, BIHSON “Detached”, i B EIER:. RiFiE
PRI “Bottom Tap”, #ix)m k4 WA 5-10.



Edit Instance Properties
oK Cancel Apply Haxd Frevinng Help
Attribute fopmantivity 4 Parameter Property ROD B Cormnan
Apply Threshold u
Gate Connection 4 HNone - Top - Botlom - Both
S/D Metal Width 1.1
Switch S/D
Bodytie Type Detached
Left Tap
Right Tap
Bottom Tap u
Top Tap
Tap Extension
Tap Contact Rows by
Show Sim Parameters

K 5-10 D “Ak” &Rz

£ 5-10 FPIRES R A “OK”, BT LAE B mn Bk BAZ Y [ 6-11. £ T 5 tH
TATERES b LA B R . AP AN AT LUK EL, A OIER EE R PHEA
J2 (SP), gktheld 1 )2 Mrief “HIRX” (TO J2). XFEiH iR T,
HT PAEB IR AR, LG Pracll BRIl A Re &8, NN P+ES
T AMEZ XS X, BIEIRIX . T EAAAEM B R, Y PRIETEN,
P+ X3 B A IEX H 5 AR A 2 .

K 5-11 HIEFET NMOS &



BUER LM —k DRC e &, #HIFILE 4%, ZRMNNE 5-12, RIARRIHA
“HOR” e R AR R, H R A S RE

Calibre - DRC RVE : inv.drc.results [fhome/cdsusr/cds/drc]

Eile ¥iew Highlight Tools Setup Help

= » 4 H »C W Z

Topcell iny : 2 Results (in & of 241 Checks) ]

[ Cell inv - 2 Results 4-Vertex Palygon
= Ck #31- 1 Result 4%, 01
2 1.9, -0.1
B Check a2f- 1 Result ig, 3.0
o 01 -1.75 , 3.9

Rule File Pathname: /home/cdsusr/cds/dre/ csmecalibre. dre_
A3 f: A3 metal density must be »30% <50%

Cell inv : Check A3 7: 1 of 1 Result

5-12 0 DRC ) @t

(4) 22k
AN I AR T RIS A, TR 4 AR A 280
N 0.05um. BN 2 52 TG GF X HE Y Bl HRERATER SR 1 RN
1.2um (L5 5 R ESR), JHERS NMOS B @i 7r, e Rk
FUE R . EE, MEEM AL (drw) BERGEG EiF.

K] 5-13 stz



(5) M€ ) 25 1) v P

Fi R (o A2 R IR M
2R N m b “dr” 15um, KR [E
T o BRIERT R P SRR, ERIE
RATHEH R LR, B “R”7 B3
ST e i P Bl <) o M X
S, BEECERAEIN RIRSL, R BEIRE
Sk, FE CR” Ex 15um B, S
— K, “R” #lEzET, BEMN
Window->fit wf G4 A7 18 %t 7= 72
Ferf,

SRJEF B CLE 3 2 4 B P2 D13
JIERHIRER, i 5-14, AH#}
T AL QAR E T .

(6) JHE PMOS &

JEE PMOS i #7157 NMOS &
FAl. PMOSEH 02 FEH I mp. §%
Wit EREH mp B EAN 2.1um,
bodytie Type i Detached, {Hi%#:07 &

ik Top Tap. & JEIRAESMN UK
5-15, PUE¥ ETHERde XN
HJRZL, N BEUERS] 1 R vdd,
ZEREL N TWAAEX, I
AN N+, {H st02 T 2475 2 m H
SN 2.

W PMOS & TTE R AH %
BT, 2T Y i, R
AR ERSRAS BRI BT
AFIETE, PG 2 R R 2 T

Hide | Cancel | Defaults
Length
Total Width
Fouger Wiith
Fhipars
Threshold
Apply Threshold
Gate Connection
S/D Metal Width
3witch 3/D
Boidytie Type
Left Tap
Right Tap
Bottom Tap

Top Tap

K| 5-14 58 m s

Create Instance

4 Hone Top Bottom Both
1.1u

Detached

K] 5-15 & PMOS & J& 1t



n s 5-16.
(7) LHEREL

AR AT EAEA 2 . A
Ho& & “ kB 7 # 1k
( Create>Rectangle) EIw], “JEH”
AR R U ) IR
[EEAE, Tk + Create>Path {14/
E (WK 517D,

(8) il 5 & )& = &R
S RE AT ENE o NP N 9 e

BOERE, AR M T B R4
J& 1EA B 5 HMBAHE .

% i 56 8 M IE R/ 1E <102 e bty
GIEL M2, i Create>Instance
&, SRJG1E 02 14k POLY1_M1_LV, (I,
K 5-18) JRIE AR E], 52 iR
REIAT (AL 5-21).

K 5-16 H&ERK PMOS &

Library Browser - Create Instance
Show Categories
Library Cell View
st02 oLl M1 Lv Jsymbolic
analoglib w1_u2 symbolic
basic w2 u3
hed05 NDIFF_M1
bed_tut EOIFF_M1
cdsDefTechLih POLYL Ml HV
fao BOLYL_M1_LV
st02 POLYZ 1Ml cap
=£3000 POLYZ_M1_res
tut PinMetl
tutl2 PinMetl
tut_st02 PinMet3d
cpip
dnpp
dppow
f£pl
Ty
nndep
mnlvt
np
Close Filters... Help

K] 5-18 % Poly 5 4 J&8 &1




(9) %M Pin

e LVS i, SAERE E
PR FLUR S HURI A N i AL
A TG E 3R 6 B A IEH .
f£ st02 T2, #iE pin REMEH
Al (Text) B, BIEFER
Create>Label . #17 J5 ¥ tH I &
5-19 s e H o K IR 2 F 5N
vdd!, RJEHAERIREE L LD
Ao HFEIFERRE R, HhER4E
FR gnd!, XL FARERE R,
[A°~ AnalogLib H ] vdd 7575 75 4 ik
spice PRI )7 5044 & vdd !, gnd
R A2 B s A4 K gnd L.

BN it opin 4 7B S E A
=2, XEH ARY . bRvETS
5 R vdd 1 gnd A7 1A

SERPRIE IR B U P 5-21.

Create Label
Hide | Cancel Help
Label wdd [
Height L
Font stick
Text Options W Drafting
Overhar

Justification ~ centerCenter
Attach

£k Rotate

il % Sideways % Upside Dow

K] 5-19 #5iE vdd [ pin

Create Label

Hide | Cancel Help
Label gnd [
Height i
Font stick
Text Options H Drafting

Overhar

Justification  centerCenter
Attach
Lk Rotate | /k Sideways | = Upside Dow

] 5-20 #57F gnd 9 pin
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K 5-21 SERk inv i &

(10) MBS EBEEX L (LVS)
7E R B 9w R T 1 S 8 ik £ Calibre> Run LVS #43# H Calibre LVS ) %
(K] 5-22 #E 7, 5-23 7E)5), Kl 5-22 j2 REUK /R 2 5 N Run Set (& H, 4N
RUIRTE R WE, rTEBNE. WHRHCEA RS Run Set, sh7ER 5-22
mi Cancel, ZAERNE FURBEIGH, B 5-23 Fos & F0k HIE B %8 L.



Load Runset File @
— Runset File Path

[mome. icdsirunsetsivs [ -

— Recent Runsets

Path

fhamescdsusricdsirunsetsirlvs

‘homescdsusrcdsiunsetsihodlys

Ok Cancel

K 5-22 Ji%) CdibreLVS

HEAER 5-23 55 “Rules” #%4H, $55E lvs BUMNISCAH:,  riddy rules & HUATL
“L7 KB HRIELE 524,

al

Calibre Interactive - nmLVS =IE)ES

Eile  Transcript Setup ﬂe\p|

Bules ~ L¥5 Rules File
Inputs [rules view | Load |

Outputs
Run Control ~ L¥5 Run Directory
Transcript |mome/cdsusricds |

Run LS
Start RYE

K& 5-23

LVS FN S RAFAE “calibre_rules” HF (WK 5-24), XdiizH%, 4

’ ARNY

JE AT H A “st02_rules” ¥ H 3%, &H)a3kE] calibrexrc.lvs 113044, 1EE 5-25
FPRAST, & “Open”, EtalhnZk Ivs B S 4F .
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i L]
(3 L]
(3 L]
(3 L]
(3 L]
(3 L]
(3 L]
(3 L]
(3 L]
(3 L]

K| 5-24 -k Ivs B ST

fhomescdsusricdsicalibre_rules/st0z2_rulses |_ \ =

=
e

K] 5-25 i 71 lvs Fi S



Calibre Interactive - nmLVS

File Transcript Setup

[=J(E]]

Help |

Bules
Inputs

Dutputs

~ LVS Rules File

ibre.xn J View Load

Fun Control

~ L5 Run Directary

Transcript ‘

|kmme."|:dsusrlcds!|vs

| |

Run LVS
Start RYE

S m#s, B EFRIZ1T B3, £ LVS Run Directory 77 1% [+

K 5-26 LHFIzfTH 3

1] “/home/cdsusr/cds/” JETHIAS “Ivs”, &5 N ik 5-26.

SRJGTE Calibre Interactive & [ & “inputs” #%4l, F7E “Layout”. “Netlist”.
“H-Cells” =N IHHE IR A “Layout” (WK 5-27), EFETHE LTI A .
¥ “Export from layout viewer” & HEI ],  FA AR i E AL E B 332 E GDSI

EENII B

~

Calibre Interactive - nmLVS

Eile Transcript  Setup

= ENES

el |

. Calibre CB |

Rules | ‘ # Hierarchical - Flat

Inputs ‘ & Layoutws Netlist - Netlist vs Netlist - Metlist Exraction |
Outputs

Layout ] Hetlist ] H-Calls ]
Run Contral
ETEENES File inv calibre.db ‘
Run LV Format GOSNl it W Export from layout viewer ‘
|

Start RYE Top Cell: v ‘

Layout Netist: inv.sp

| _vew |

K 5-27 BRI S A ST




SRR R “Netlist” 1 3% J5 B SO o 4n SR i 28 PR A0 P 55 i P AL PRI 7 ) — A el

T, & “Export from schematic viewer” Bl H],

I~ Calibre Interactive - nmLVS

= [a][*

File Transcript Setup Help |
Rules ‘ | & Hierarchical - Flat - Calibre CB |

| Inputs

| & Layout vs Netlist - Metlist vs Netlist -~ Metlist Extraction

Qutputs
Layout ] Nemst] H-Cells ]
Run Control
IR Files inv.src.net

o] | e |

Run LS Formnat SPICE  —t

W Export from schematic viewer

Start RVE Top Cell:  |inv

-

K] 5-28 1% i 2 ] B N S

RS, & Caibre Interactive 7 11 H 1 Run LV S %40 5 7] 5 2

LVS 7. RIGEMHME DR —H s “yes” 5 “OK”, LVS X Hbgh o Ja sk Y
I 5-29 Fintd Mo Wik S FEEE—2, 5 0B K7, A —

B, 4R,

Tw Calibre - LVS RVE : inv [fhome/cdsusr/cds/lvs/svdb]
File  ¥Wiew Layout Source Setup

=[a][*

Help

B~ B 3

Input Files ?. LS Results: Designs Match
% Rules File < @ inv £ inv

< Source Metlist
Output Files

< Layout Metlist

< Extraction Report

< LVE Report

Discrepancy Infarmation

Query Cell: iny
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IBH Calibre i, REUHEHERZE B IR/ Run Set, F O Run Set g4, I/
1%l /home/cdsusr/cds/run_set/1, I AE A BEH 1% Run Set RIFT 1247 LVS,
SORHE I R AR BT 45 RS, 24T — IR DRC, WA ER < J& AR [v) AN AT
H& DRC 4%, LVSi#id, #iiF B BT & IR .
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6.1 915

LT DRC Ml LVS H RS AR BT A BRI, (R BECRIERR B 1 T &
PR AR B, 75 S B B ) o () B A R 1 (R B, I 2 A o — o 3 e
A HIEE, IXFPERERR B A 2 T A S8 W B AR B R s 27 AR F R
FELRELRT FE R, A N 2 IR A ) AR N = S R R AR o A AR AR R
WA, SRR AAE W] BeXS B I P Re e AR — e s, P E R A
SRR SRR N Z EFE T AE S RIS 0 5, BTl R B
R REUH A& a8 K BB R BEAT O B, L RS i i 5
o

RN FFE T, ) Calibre xRC REVEFESH, FH4ERK Hspice i
RSO BT H AT Cadence M8 A SCREAE B Y FL I ELHz%T Calibre xRC 4E
FRESCAEEAT A B, BATE ] Windows Al A Hspice SR 578 5 17 B«
6.2 IEMHFLESH

FAESHE NI E RS, I e R E N Cadence, FEFTIFIEILEL

/irtuoso® Layout Editing: w0z inv layout
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FARAS I E & 6-1, fERR M SidE e 1, 5$F Calibre>Run PEX R3]
Calibre 77 S BRI LA, ST /RR HILE 6-2 Fron e 1.

fF -
¥ Calibre Interactive - PEX M= E
File Transcript Setup Help ‘
Rules | — PEX Rules File
= hd Load Runset File *
Input Load
— Runset File Path
Qutpu
|fhume!cdsusr!cdshunsetsmcdpex
Run o
Transcl _ Recent Runsets |

Path

fhomelcdsusi/cdsirunsetsfcdpex

fhomefcdsusrcdsirunsetsirpes

Fun BH
Start RY

9,4 Cancel

K 6-2 a3 CalibrexRC

WRCARTE L RO R 7 W E, BN Run Set Bim), X BB EH X
AT IZHAE . S “Cancel” 51 Load Run Set File 1% 1. UL F#4E 51l RDC
ALV S B+ AH4RL



!humefcdsusrfcds

Q
| senrve |

S
Kl 6-3 i BRI SC

£ /O i vl 7 QS S/ U S S ST QS U R g

“/home/cdsusr/cds/caliber_rules/st02_rules” T, il 6-3 “PEX RulesFile”
1“7, HEBRITTTFHZ, ®EEDIHE 6-4.

fhomescdsusricds/calibre_rules/st0Z_rulze I_ | £-3

"
preese

Kl 6-4 f5 &N SCE

TE 6-4 Wik “xrc_a3.rul”, PR “Open”, BIRTINEFN S



Calibre Interactive - PEX : rpex [[home/c

ome/fcdsusricds/calibre_rules/st02_rulse/zre_a3.u

Mhome/cdsusricds/pex

K 6-5 Eiiuatr Hx

WEEHN A, — R E IR T Hax, BAEERINA “/homelcdsusr/cds!” Ja
I FHE E pex, WL 6-5. fJr, £ 6-5 PraniRas h, 1% “inputs” #E A
ANSCAFIIFAT

veabredy |
= |

|
X 6-6 BLEAREHA

%K “inputs” J5 75 EAEE “Layout” A1 “Netlist” N E . K 6-6 /& Layout
YR N BRI E . “Format” Bk “GDSII”, “Export from 7 Fi [/ 7 B



k. SRERE Netlist FTHIRE, MUK 6-7. i PEX B, Calibre ¥ 8t
AT—IR LVS, A i A iR 28 ] S B 4 e, DA b ade 6800 2 A A4 M i [ R T
FEFE A E R B R EL, E— cdl 7, IX AR D A AFAE A BE R A AR

%
ZH

b Calibre Interactive - PEX =[]

File Transcript Setup ﬂelp|

Rules Layout ] Netlist] H-Cells ] Enocks] Probes ]

Dutputs | Files: inv.src.net jJ Wiew ‘

Fun Caontral

Farmat: SFICE — W Export from schematic viewer
Transcript

Top Cell:  finv ‘

Run PEX
Start RME

K 6-7 BLEEE A
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a7 Calibre Interactive - PEX =N ES

File  Transcript Setup Help

Bules
g Exfraction Type:  Transistor Level | R+ C+CC| MNolnductance
Inputs
Dutputs
Netlist] Nets] Reports ] SYDB ]
Eun Control
Transcript
Format.  HSPICE | Use Names From: SCHEMATIC | |

Run PEX
g File: |inv_rc.sp Wiew ‘
Start RYE W View netlist after PEX finishes |

K 6-8 2 th S 44

7E “Outputs” 2 FHPIRA, “Netlist”, “Nets” Z#E/ A . Netlist R File
ZEBUON* .5, Bl inv_re.sp, FONIZSCH 5 EHE DLE Windows M55 T, §7 &
402450 sp. Format 458 HSPICE, Use Name From J& Eik SCHEMATIC, =
RURM A R EE 2 4 . 1% 6-8 AT LiR)E, AL “Nets” #ENF—IiKE
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K 6-9 LLFEHEHUM 2%

K7 Nets N E, Extract parasitics for: J& L4052 All Nets, = JEEHRE
FI A WX 4% 1) 25 A 24
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T Run Control J5 ¥ B M 4n Kl 6-12. REHERIA M) “Run Hierarchical version of
Calibre-LVS 7 GZ1TEILIRA LVS).

SERCA EAS A TAE M AT DL AT IR BUEAE 1, siT i), — & EAER S
TRAFF—A> Run Set, FAEAR, E#EMA Run Set BIAT,
s Interactive & 1) Run PEX JE SR B, 7E52 T 2R H A # 17 & 1 —13 5 Yes”
B “OK”, Iafr 4 RN Hi I 6-13 M 6-14 fon e .

Calibre - LVS RVE : inv [fhome/cdsusr/cds/pex/svdb]

Eile  Miew Layout Source Setup el
= E
= ~ Y HE z
Input Files & LVS Results: Designs Malch
¢ Rules File < 8 inv /inv

< Source Netlist

i Qutput Files
> LW 5 Report

Discrepancy Information

Query Cell: inv &

K 6-13 LVS 45

PEX Netlist File - inv_rc.sp
File Edit Options Windows

* File: inwv_rc.sp

+ Created: Wed Sep 15 08:41:18 2010
* Program "Calihre =RG"

* Version "w2008.1_32 21

*

.include “inw rc. sp. pex"

.subckt inv GHD! VDD! & ¥

*

*Y ¥

* A A

+ GND! GHOD!

* ¥OD! vOO!

MNMO N_¥ MMMO d N_A MWMO g N _GND! MMMO_s N_GND! MMMO b NN L=5.5e-07 W=8e-07
+ BD=§ de-13 RS=§ de-13 PD=3 Te-08 P5=3.Te-0f

MPMO N_Y MPMO_d N_A MPMO g N_VID! MPMO s N_¥DD! MPMO h NP L=5.5e-07 W=2. 1le-0&
+ BD=2 GZe-12 AS=2.52e-12 PD=6.6e-06 P5=F.Ge-06

*
cinclude "inw ro.osp. INV. pit
*

.ends

*

Row| 1 col[ 1
Kl 6-14 #ith SPICE U4



HI T84T PEX B HEHET T — X LVS #AE, H8 HILE 6-13. & 6-14 M2
B S FES R, R “NN” A “NP” = AXH, BUE DG
FI TSN AR Sehr EAE “inv_resp.pex” A1 “inv_rc.spINV.pxi 7 T,
R EE O ARSI A REE BN A .

Calibre xRC “E 1] Hspice #& U3, H ATIEASBE H#24E Cadence 55 T
PiE. E4EmAET, 4148 Windows 115 K () Hspice 47 G . NME T
TR AR, EFEASHFESEUN Hepice MMM R I, BT
WA B P AR

Virtuoso® Schematic Editing: tt02 inv_tb schematic

omd: Sel: 0 8
Tools | Design Window Edit Add Check Sheet Options Migrate Calibre Help
AMS Opts.

Analog Environmen 13
Design Synthesis
Diva
FloorplanfSchematics .
Hierarchy Editor
Mixed Signal Opis.
PCM

. Parasitics
Schematics
Simulation

Euu. e ]
e | TR
d

-

Lo

nouse L: schSingleSelectPt() M: schHilfousePopUp [}

olm &8

K] 6-15 {77 B LK

MAGE R PR E (DL 6-15) 3 N\ Cadence B4l ¥Eit 308, SR)51%E HSPICE K
fFE T E. F Simulate>Netlist #:4/F (LK 6-16) B4 KN E.



Status: Ready

Virtuoso® Analog Design Environment (3)
T=2a C Simulator: HSPICE

Session Setup Analyses Variables Outputs Simulation Results Tools

Design
Library tut02
Cell inv_th

View schematic

Design Varables

¢  Hame ¥alue

Hetlist and Run

Run
#  Type IStop 0 | Enable
Options
Hetlist Create
Output Lﬂg ooo Display .
Convergence Alds - pocreate
UUpULS
#  Name/Signal/Expr Value Plot Sawve March

Plotting mode: Replace

K 6-16 4 pi—4> HSPICE #% 2K [ W 22

HPLE 6-17 Pron i) Hspice #§ A SCF IR, PRAFS]—4>.5p LA



Q{c_.dsusrfsimulationfinv_lbe SFICE/schematic/netlistfi i

Help | 12

Generated for: HSPICE

Generated on: Sep 17 14:52:51 2010

Design library name: tut02

Design cell name: inwv_th

Design wiew name: schematic

.global 0O wdd!

.option search='."

ctemp 25

.option ARTIST=2 PSF=2

*  Library name: tut0Z

* Cell name: inw

*  Wiew name: schematic

csubckt tutli_inw schematic a v
mpml v 3 wdd! wdd! mp L=EG50e-9 W=2. le-& 2D0=2.Ele-12 a5-2 52e-12 PL
mrm0 ¥ 2 0 0 mn L=550e-9 W=800e-9 AD=840e-15 AS=840e-15 PD=3. Te-6

. ends

* End of subcircuit definition.

EE S

*  Library name: tut02

* Gell name: inw_th

*  Wiew name: schematic

%15 a vy tutll2_inw schematic

cl v 0 1e-15

wl wdd! 0 dc=3

vl a 0 de=0 PULSE ( 0.0 3 1e-9 100e-12 100e-12 Se-9 10e-8 )
cend

& 6-17 Hspice 14

Save As

OK | Cancel

Fle Hame | CfpexSinw_sch. sp |

K 6-18 frAF3Cft (BBCCE4)

DL SRR B B T 05 2, SRR A TSN DU I TR
Windows FREE FHEFT, MO0 SO AR, UlnEdit.



6.3 i &
M Calibre xRC A= iSO R R IS B — NS 2 AE S B F g, nlk Hdr
LN inv_re, SCHEH ISR 42 T AR e S PR AR A 2 A5 2

* Fle inv_rc.sp

* Created: Wed Sep 15 12:15:41 2010
* Program "Calibre xRC"

* Version "v2008.1_32.21"

*

.include"inv_rc.sp.pex"
.subcktinv_rc VDD! GND!AY
*

*Y Y

*A A

* GND! GND!

*VDD! VDD!

MNMON_Y_MNMO dN_A MNMO_gN_GND! MNMO_sN_GND! MNMO_b
+ mn L=5.5e-07 W=8e-07
+ AD=8.4e-13 AS=8.4e-13 PD=3.7e-06 PS=3.7e-06

MPMON_Y_MPMO_dN_A_MPMO _gN_VDD!_ MPMO_sN_VDD! MPMO_b
+ mp L=5.5e-07 W=2.1e-06
+ AD=2.52e-12 AS=2.52e-12 PD=6.6e-06 PS=6.6e-06

*

.anclude"inv_rc.sp.INV.pxi"
*

.ends
*

*



R A HLR BRI 1G 210 spice SCPF A -1~ FL it ASM A 70 M, IR 7 AL 44 2

A inv_sch.

*  Library name: tut02

*  Cdl name: inv

*  View name: schematic

.subckt inv_schay

mpmO y avdd! vdd! mp

+L=550e-9 W=2.1e-6 AD=2.52e-12 AS=2.52e-12 PD=6.6e-6 PS=6.6e-6 M=1
mnmOy a0 0 mn

+L.=550e-9 W=800e-9 AD=840e-15 A S=840e-15 PD=3.7e-6 PS=3.7e-6 M=1
.ends

wJh, BOWmE —AMFE S, SFFFEBIN EFEFERES, WL T
FIX . R, PLEATA SO ARALE R —AN H %, F£H .OPTION search i 4]
e ZH .

*

.option search = "e:/inv"
Jib "h05mixdtssa01v11.lib" tt
.global 0 vdd!

*

inc"inv_rc.sp"
.inc"inv_sch.sp"

*

x0vdd! Oay rcinv_rc

xlay schinv_sch

vlivdd' 03

cly rcO1f

c2y sch0 1If

v2 a0 pulse030.1n 0.02n 0.02n 0.5n 1n
tran 0.1p 1.5n

.end



7E Windows F J3 3l Hspice, &l 6-19, w753 6-20 Froniiff B R .

Er a@0)

Design |e:\inv\iny_th_sp

Title |x

Listing |e:\inv\inv_th_lis

Version |C:ysynopsys\Hspice2002.2 2\BIN\hspic ~| MultiCpu Option :II

‘ﬁﬁ% ERRE

Open Simulate |Avanwaves EditLL Edit NL

i

Multi-jobs

VER:2002.2.2

%] 6-19 Hspice & 3 & [

6-17 itk

ME 6-17 KE, FRUTRSEGREGRITEZERNAR, BIXABY]JE {5 EBAT 24
o ZHEE 05um TR FZET], FAESBA BN WREFFIE
FOT/N, HBRES RS, WSRO AT REA BRI .



78 ROt

71 55

Cadence BT I8 A0 3402 SCREZ AL BT, BB SEILE KB B . 8
B S5 5 . R hl ot —BeRH 2B Rm B dt g, B e idE A
BT HLES BT, PR A BT I A B T HL B S S SR AR K BT L, BB
JREEAN LR ¥ 1T . Cadence DFII MREE D) REAR S8, 7ERAHZSBH R [ T 6 5
THEE A R, RN 20 75 B BE B A B TE S o A & DA — MR 25 L o
B Z AT IR A T
7.2 PR 4 R

PRk ik 7-1 s, BRI AR I T2 M S80S /1L b RUSE R
B ARIE o R E AT IR &, 58 B TR (K SR 28 35t 2 i 2 R SR 7T HY
e, AT ARG A m— AN R TR R, J5 2 PRI 400 I A i L
) 5510 B 4 ST SR 8 BITEE R R o o AR B A 2R A2 R L I A SR A i)
@, HEABES N 2—6 &,

7-1 3525 A

(1) g7 7 2 LA

FE TUTX (ABEPTERI ) B @ sr — AN s B SRR LK, dir 444 osc,
BAHEHINES WA 3 7o
(2) il R EE

Bt Al g <A SarEp g inv (GLEIE. fF5EL A CAE),



EB Bﬂ{éﬁﬁ StOZ E‘:F EP H(] rp0|y2 I Library Browser - Add Instance

Show Categories

(K 7-2), TRMF 2EZ Library cel View
Ftiz rpolyz Jeymbol
HEEI ifm E/\J Eﬁ Bﬂ ° ana]__ongb bie) autdl
hasic npdep aulvs
'_‘_’ . hecdls mp:!_vt symbol
AR R 02 ) pip e ringioss
fac qunllba
v £02 20b
(L 7-3), ZRMWEZ S ww s
tut qvp
ST FaL. s 5
rrplus
R, EBHLEEHA enell
e

RefdiH Andog 2 R dh 5 repolyL
PELAIT L2, DRl Dy 3K 6 Fi BELAT F,
BRI N, 2
i R S

(3) Bl Library Browser - Add Instance

Show Categories

A HRE, SEMEERE Library cell View

Close Filters... Help

K 7-2 e SRR

jst02 Iepip jsymbol
HIVEIEE O (LA 7-4), B [eloa Pirketd sl
hedds dnppw hspl:.ce
BELASIREAE A FH T HBCRIE (1, Saermecman e cotmen
fso n symbol
FRHCUR AT SRR, e =
n g
tut02 npdep
LER R LA B, e =
primRes3
St02 (¥ 4 B L BHL A 98 A2 anione
TP,

quplld

[ 5 17, DRI R K B R ap20
“itE 2 %7 (Cdculate

Parameter) . IX i FEL{E AT 41\
RICBCE A O (TR
W, FRERIR SO, SR A3 KR
HASHESUNE S BERL, WK 7-5, XEH “UHHSH” EE, AR
EACE . H BT R EARAIEA S IR RIA], 50 B A B2 7 S I B T B e 1

2

JE o

Close Filters... Help

K 7-3 i A R



OK  Cancel Apply Defaults Previous MNext Help Edit Object Properties
OK | Cancel| Apply | Defaulis| Previous Next Help
Apply To only current . | instance
Show system M user W CDF Apply To oniyjewrent Istance
= Show system M user M CDF
Browse Reset Instance Lahels Display
Property s Display Browse Reset Instance Labels Display
Library Mame | 3£0 off Property Value Display
Cell Hame rpalyZ value Library Hame | 5t0% off
view Name symhol off Cell Hame cpig value
Instance Name |l off G [ ] =
Add Delete Modlify Instance Name G0 off
CDF Parameter Value Display Add Delete Modify
gl nEns rpoly? off 5
. CDF Parameter Value Display
Multiplier 1 off
= EHoda nane cplp off
Segments i3 off =
. Multiplier 1 off
Segment Connection Series off
o] cactate Parameter |_with | art
Calculated Parameter off S
T itans E off
Resistance 5K Ohns off Capacitance
- Watih 23u off
Segment Width 1inm off -
30.105u i off
Hogment Loaghh 12,1550 B off Length 1
o2 papanianay {57 0.00072 off
fisten e h 13 n off fArpa paparitanee (FIMO23
Fioen e een o ]
fiftonthen Langths 101,550 1 off Frings capaciianese 544} off
Left Dummy off
Right Dummy off
- =~ )
Contact Rows i off K 7-5 RN
Cupdae? CaBmms 1 off

K 7-4 R pH

(4) ARSI

L EOR G I B 5 AR At S AL, BARIRIES L
BT R EEIAT, KK 7-6

1T, R EFERnEAR Y,

3 &,

PRIAS 2 bn i 45

K 7-6 75K

(5)  rHEIKE

AN

PRI, (B4 IR —

A B SRR AL
AN S5, ARARERIR, BarrIJriE 2 PULSE &Y
AN i FLP I TRDEE S 7 L BTN 1), I REIR

4N osc tb, WK 7-7,
EReR/ AR/ R

PRz a5 5%

< s [R]

AR OfE (LK 7-8), Hislfig B RE, JRizasmiaEwEdk 1.



7-7 15 R

CDF Parameter Value Display
AC magnitude off
AC phase off
DC voltage off
Voltage 1 0.0 % off
Yoltage 2 3% off
Delay time L s off
Rise time 100.0p = off
Fall time 100.0p < off
Pulse width 100 = off
Period 200 = off
Frequency name for 1/period I off
Noise file name off

| 7-8 PULSE %k

(6) EHT
AT SO A5 EAR TR, (BT A 7 BB 2R, RS AR A
T HEIE PN A N I captypical Al restypical (WL 7-9).



spectre0; Model Library Setup
oK Cancel | Defaults| Apply Help
#Disable |Model Library File Section -
Ennhie
Jhome fcdsusr fcds/spectre_models/st02/505mixdtssallvll. scs captypical
Jhome fcdsusr/ocds/spectre_models/st02/s05mixdtssallivll. scs restypical Srgabia
Jhome fcdsusr fcds/spectre_models/st02/505mixdtssallvll. scs tt
ih
Dawn
Model Library File Section {opt.)
I
Fudit Dmlwin e gt P Browse...

7-9 BERIEERIN I

DL ETHES S8, 47BN A 100ns, T 152K 7-10. 117 H i A 45
fH, EXEBHEAA vdd BB ERRE N 3V, ST BRI EEE R,

tut02 osc_tb schematic : Sep 21 08:55:59 2010
File Edit Graph Axis Trace Marker Zoom Tools Help

SrEEl FEE S ¥ BN Xt e |

Transient Eesponse m

e e . e S e . S S . o e . s e s s

o] 25.0 50.0 75.0 100.0
time {ns)

K 7-10 1/j EL45



(7 RAETANE
H 05 B B R R0, Dyt G A CHR SR B EL, AR AT B E IR AR
fER M Analog it AR E N, BAF a4 DN (LK 7-10).

Save State Query

Do wou want to save the current state?

Yes Mo Help
7-12 WH & H

A Yes K LK 7-13. FH i) statel BONETCZ 004 %, W osc_stated,
SRJE R OK,

Saving State - Virtuoso® Analog Design Environment (1)

OK | Cancel | Apply Help
Save State Option # Directory Cellview

Directory Options

State Save Directory /. artist_stated Browse...

Save As statel;

Existing States

Cofiviow Qplions
$#mwary i

Lol Bnwse...

eals
Desctiption
What to Save
Select All Clear All
W Analyses MW Variables N Outputs
H Model Setup H Simulation Files H Environment Options
H Simulator Options H Convergence Setup W Waveform Setup
M Graphical Stimuli M Conditions Setup M Resulls Display Setup

M Device Checking Setup M Distributed Processing

Kl 7-13 154 state %

N UGHE AN BT AL, R section>load, HHILE] 7-14, EHERAEK)
A, R OK RIS JER B



Loading State - Virtuoso® Analog Design Environment (2)

OK | Cancel| Apply | Delete State Help

Load State Option # Directory Cellview

Directory Options

State Load Directory o/ artist_stated Browse...
Library tutn2
Cell osc_th
Simulator spectre
State Name

Coiiviaw (halinng

7-14 MBI R K E

(7 At
£ osc T AL —MRIESER AR, C 58 il BB 0 SO 2 AT RAAE 9 —A
R . #Edr 48 Create>Instance, 28 J5(EFHH A% H 34k, LI 7-15.

K 7-15 A inv

r a
Library Browser - Create Instance
Shows Categuries

Library Cell View
o0z Hiwr TLagout
analoglib irw calihbre
hasic inv_th Layout
bed0s 0sc schematic
bod_tut oscl symbol
cdsDefTechLik o5
fsc osc_th
st02
=t£3000
tut
tutl2
tut_st02

Close Filters... Help



BRESINE 4 N gs, RATpE R &R, BHX AT LA IR, (H PHEA
[X F51A1F% 0.8um, #RJEH M1 24 vdd FI gnd JE#EEEK, ikl 7-16. 7EIXFhF L
NEEEAT X DRC fa &, MERA AW DRC ik ()& AR A%
8o WERBATHE AT vdd B gnd SERER, K IUHTH) DRC #4i%, KN4
WS pin bn5 CAEAE R, BER BRI AT 22 Rl JIRE 3%

K 7-16 HEB A 2S

NS ATREJ/INIEIAR, W S22 5 4k 4 A4S Bt ds e 180 1 ) AU E.
fiE N BFREWS G IF . iediR(F 2 4E Move BEaUh i BUbR A o o



RN ZINTE AR LR, RO N SN S AL AL, fEBFHE vdd Rl fL &
Fro FRIRZRTE L TR EARE IR R LR E , R IR D, B Rk
WiRM, FAERLEE LY 1.

7-17 DL/ IX T AR AT )

YR — MBI B 1 AR S T LS TR RN E R 1 A48, 8 EF
PIAT BTG gnd 4@ 2k Rtk (&l 7-18), Ffit—k DRC, i A #iif) DRC
RS NN ZE EPE, ] 7-18 e 2R R EE YR N 2.4um.



K] 7-18 8 N [ AH 25 1947 =)

EE‘BE‘%EEIJ Stoz E:F E‘ja&jz ’ EE‘ Library Browser - Create Instance
BH 2K 0 200 5 T B — 3, Do e

Library View

. . stz Jrpoly2 Hlayout
%jﬂy&j\j |ay0Ut ( W_,Ig] 7'19) o 5'6 analogLih T aucdl
haszic nndep aulvs
.y W s hecdlS mnlvt ivpoell
ERBOASHORA, FHRYEIRED e, P b
faco mp¥vt symbol
V] ) BELAPL AT PR 7 B TR R A brianess
) = el
BRI B K Lo .
e
rhr2k
cnplus
cnpolyl
rrwell
rpolyl
Close Filters... Help

K 7-19 JiEHH



K 7-20 1 & BH A5

BRERANTESE, WMANTERE, HREBEERMERHmRAE LK
7-20). HZELIF TR E R (I 7-21),

7-21 BEARA JR

B AT =3 i it % SR B LR T RN R R B )R 12 (L4

B, & 1EENENHHERE 2E (26, 1185 2 A (8 S0 A fL g

(st02 EHF ) M1_M2). 2 fb B AT AR BE 4%, (HABESEEAURIX . FE ik
PR E L 7-22,



7-22 ERARF

vdd F1 out FFEH 2 4851 H, kxiE PIN BHER M2 (TEXT) 2. #2375 <A
FEAFBI PIN ARVEAEAIER, (RA I T 7 (14 0T A 75 24 8 H i 284 Ceel)D
“PRT, fEHAERIEE, BREJTEE N Edit>H>Flatten, XL Y PIN
PRV



SIS R IR ZR Al HE 2 3T ML AN IR A 32 Ak A LA vdd S BFIRIEAm£L , )
oA B BH, S MOS EARHALRE) (LI 7-23).

L gl i i e il e i i

7-23 ML 5 AR I EREAL

A E L 7-24, AR AR B i 250, BT /& 2251 K PIN
B B AL, TR P

7-24 IRy, as A R



(8) hE%IE
DRC 1 LVS #:AF 7E 5 A # B A Rl . A2 Ha % 1K) DRC 175%R 7o
SR, EAREHEHIR,

Calibre - DRC RVE : osc.drc.results [fhome/cdsusr/cds/drc]
File Miew Highlight Tools Setup Help

¥

& ~ 4 H »C W Z

Topcell nse - 3 Results (in & of 241 Checks) ]

E Cell osc - 3 Results

& Check &1.noted - 1 Result
[ Check &3f- 1 Result
X Check &2f- 1 Result

Cell osc : 3 Results

K 7-25 FuVFRT DRC [ @

Calibre - LVS RVE : osc [fhomefcdsusr/cds/lvs/svdb]

LVS &2
@ik, BEE o s 5 =
FoRmmEn Lo,  WESETT
B, e B A B % g%%%
F 2 30T i T
VLR, 7EiX A
MR, A LE
L, 7
7 J5 B I oo B
BRI e .
¥, WS IR K 7-26 LVS 45 1
BRI 55 K
R .

Discrepancy Information




(9) RWFAESHMENE

BAEENE 6%, JFiR
7.3 4iiE

ARURFELLES] EDA THENFEHbr. FATELH MBI LBIANHE T 4
WA ISP IR LA K Cadence 1 Calibre B fl 323t EDA T HL [ S A% H
Jiite WX A AE ], WA BT X ss EDA AR B2, A
AR R X 2t EDA TR Thae, ZEATIRNER, 167 ZAESLhs T2
e r 4k 2 2 SR 5T
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